Better Touch Tool 2 finger swipe to hotkey in Safari no longer works properly. Works fine in BTT 2.0

2017 non touchbar MBP, all software updated

As you know, by default if you swipe back in Safari, it reloads the page after going back.

If you use command+ arrow hotkey instead, it does not refresh.

For years I have mapped the swipe gesture in BTT to be the keyboard shortcuts, which lets me go back a page without the annoying Safari refresh.

This no longer works.

When BTT is mapped to execute command+left arrow to go back, it no longer does it. It just does the default safari "back" option. You can test this yourself by mapping ctrl+left arrow to the gesture. The gesture does not perform the same as the hotkeys do anymore.

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Macbook Pro Non TB trackpad

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version: 10.14.5
  • BetterTouchTool version: 3.0+

**Additional information: gesture mapping 2 finger swipe in Safari works as expected in BTT 2.0
in BTT 3.0+, mapping ANY gesture to the Safari forward or backwards hotkeys does not execute the hotkeys, it just executes a traditional Safari swipe, causing the animation to trigger, instead of skipping the animation like the hotkeys do.

Do you possibly have this option enabled:

Some users have reported gestures do not working after waking from sleep until restarting BTT manually, I currently suspect this option could be the problem.

I'm not sure if I had that changed, it would just be the default

however, ALL my other gestures, even in Safari, worked fine- three finger gestures remained unaffected (my programmed ones), only the 2 finger ones had a problem.

If you like, I can update again and try that. I've been a long time user, and literally would abandon Safari if not for BTT. If you have any specific troubleshooting youd like done, I can do so.