BBT sometimes failing to execture "Menubar item", how can I troubleshoot it?


I have BBT in a setup, so it supports my workflow in Final Cut Pro.
Currently I have one keystroke (J) defined, which triggers some actions, around 10 actions to be more exact.

Sometimes (and I really struggle to find out when and why exactly this happens) the action No 8 is not executed, which is "Trigger Menubar Menu-Item".

Can I activate some kind of log in BBT? So I can see, why BBT was unable to execute the action? Or maybe to see, if there was an issue with another action? Or maybe you have any idea, how I can troubleshoot this issue? Thanks :slight_smile:

Yes, Priority Process helper is already activated and running.

Could be the app you want to control is not yet ready. Have you try to add a little delay before that action?

I tried mostly everything I can imagine of, yes I tried with a delay before.
Which "app" are you talking about?
I am using Final Cut Pro, the application is in the foreground while pressing my BTT keyboard shortcut :slight_smile:

Is the action "Trigger Menubar Menu-Item" know for being a bit lagy?

Is there a detailed log somewhere, where I can exactly see, what BTT is doing in the background? That would most likely help to find the root cause. Thanks anyway for the amazing tool!

I was talking about "Final Cut Pro" not being ready.
No the Trigger Menubar Menu Item action is usually not laggy.

BTT does save it's log files to ~/Library/Application Support/BetterTouchTool but I don't think they will contain anything that would help for this as it's most likely a Final Cut issue.

Maybe the menubar item is not available under certain circumstances, in that case BTT won't be able to trigger it. Or maybe the name of the item changes based on context? You could try to trigger it by position instead of by name, or you could assign a keyboard shortcut to it, and then trigger that keyboard shortcut with BTT.

Ah to be honest, the delay I tried was 0.1 seconds... So I am currently trying to increase it to 1 or 2 second. I will test again tomorrow.

Just for my general understanding:

What happens with a BTT command towards FCP, when FCP is laggy, or when FCP is even showing the colorful spinner wheel? It goes into the black hole I guess? :slight_smile:

Laggy / spinner in general should not be a problem, it will execute the command it receives from BTT when it's ready. However if at the time of the command some internal flag in Final Cut Pro says "can not trigger menubar item", then it will just be lost. BTT doesn't receive any acknowledgement from other apps about the executed action.

When experimenting with delays, I'd recommend to use BTT v3.785 as there has been a fix related to the delay duration.

Already updated to v3.785 this morning (and saw the release notes) :slight_smile:

Yes good point. I'm trying to assign audio roles to a clip. Before that I cut clips and press "C" to mark the clip. Only when these actions are completed the action in the menu bar is available.

Anyway I adjusted the shortcuts and will do some more testing tomorrow. Thanks for your help!