Auto-disable smart quotes when editing scripts

Hello,

When using the “Shell Script / Task” Touch Bar widget, I noticed the dumb quotes ('single quotes', "double quotes") were still being replaced by macOS as smart quotes (‘single quotes’, “double quotes”) in the script editor.

In macOS System Preferences > Keyboard > Text, I do have “Use smart quotes and dashes” turned on according to my preference. But when editing code, such behavior should be automatically disabled since dumb quotes are used way more frequently than smart quotes in code. For example, Script Editor.app neglects the fact that I have “Use smart quotes and dashes” turned on and uses dumb quotes by default.

Thank you in advance!

Imprint | Privacy Policy