Arrow action triggering Mission Control

I'm having a really weird issue with any btt actions that have a shortcut with an arrow in it. Any time I trigger an action that has an arrow in the shortcut, it opens up Mission Control after completing the arrow action.

I've tried restarting, wiping the data, and reinstalling, but nothing resolved it. I also disabled all Mission Control shortcuts in my System Preferences.

After wiping the btt data completely and reinstalling fresh and restarting the computer, I created a new kb shortcut to test if it was fixed. The trigger was set to the A key and the action was the Arrow Right Key. Nonetheless, it was not fixed and pressing the A key would then cause mission control to open up after the arrow action was completed.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
So far I have tested it with the mouse, trackpad, keyboard, typed sequences, and midi and all give the same issue when the action shortcut contains an arrow.

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook Pro 2017
  • macOS version: macOS Cataline 10.15.2
  • BetterTouchTool version: 3.261

Weird, what does your config in System Preferences => KEyboard => Shortcuts => Mission Control look like?

I had disabled everything from mission control shortcuts to see if it would fix, but it didn't.

That's really weird!
I can't reproduce it here, is this happening on the Macbook keyboard or on some external one? (Or both)

It's happening on both. I tested it on the built in kb and tried on 2 other keyboards i have. But it's also happening with other inputs, if i set the trigger up for trackpad, mouse, or others.

And it does NOT happen if you press the arrow key manually, correct?

ya, if i press the arrow keys manually, nothing happens. It's only happening when I setup any action with arrow keys in btt.

I have no idea what could cause this :slight_smile:
Maybe open the BTT prefs, go to help => export diagnostic debug information and send the result to, maybe I can see anything suspicious in the logs!

ok thanks. ya, it only started recently, but I haven't installed anything to cause it to happen. I'll send the debug info asap. Thank you.

Unfortunately the logs don't show anything weird and your config works fine here.

Do you have any other app running that could intercept keyboard input? Is there any other app in System Preferences => Security & Privacy => Privacy => Accessibility or maybe in Input Monitoring?

Or maybe something configured in System Preferences => Mission Control?

Arrow keys may contain a fn key modifier, but the ones coming from a real keyboard also do...

I believe I found the problem. I had the settings exactly how you have them in the screenshot and the issue was still happening. Anytime I would switch to any shortcut for MC, it was happening.

Finally, I tried the fn shortcut for MC, it still happened, but when I switched out of the fn shortcut, it was fixed. Set it back to fn and it happened again.

So, this issue only happens when the MC shortcut is the fn key.

It seems as if my mission control setting was internally stuck on fn, even though I had it set to off.

Anyways, thanks so much for your help and looking into this issue.

1 Like