AQT FAQ: GameMode Install Issues

it seems like ruby installs are a recurring issue with iStats . Let's discuss a solution here

Try this guide:

@thomascanndrum @wesbar

Hi Yuuiko, first things first thanks for the great preset !
On gamemode, I tried to make it works but it still does not.
Here what I have done:
I am on Catalina.
note: I am way not expert in terminal or whatsoever

Attempt 1:
I did not see this thread first so I google what I could.
gem install iStats did not work first because I did not have the write permission.
so I did the gem install iStats --user-install
The installation seems to be working but got warning on PATH issue. (You don't have /Users/xxxxx/.gem/ruby/2.6.0/bin in your PATH)
so then I found this link to edit the Path in the bash profile.
in the terminal, then by entering Source and then the ECHO check, istats was running in the terminal. but I closed the terminal and relaunch stats it would not work - gem could not be found.

Attempt 2: I found this thread
I tried first to uninstall whatever was install before using gem uninstall istats --user-install and gem uninstall istats -I "can remember the path" but it did not work. it says istats not installed. whatever then.
I followed then the website in the thread. installing Xcode tools. updating them.
Then it asked to brew install ruby. error message. no brew can be found. so then I found This website to installl the missing brew:
it installs ruby 2.7.0 though (on Catalina it is 2.6.0). installation went well.
then for steps 3 and 4: fortunately in attempt 1 it explains how to change the bash profile. so I edited the file to add the 5 lines. My terminal is in zsh so it did the same changes in .zshrc - in a "we never know" sub-attempt (can't recall if I actually edited the zshrc before or after installing istats).
then did the gem install istats --user-install went ok.
istats all command worked. I rebooted, reopened terminal, typed istats all. it works.
(without needing to use the command Source).
Launch game mode via the Touch Bar quick controls, swipe until "switch to gamemode". The logo appears but no numbers.
I was thinking maybe the shell script (to get istats data) in the config does not work for my case ?
thanks !

Whoa that sounds super promising!

I think the last thing that youd need to do is check what command AQT is running as maybe you installed it differently.

Once its working in terminal its very easy to just plugin to AQT.

Find the gamemode widgets in the apps list, from there I'm sure you can figure it out as you've come this far. Their code is pretty simple, they just run a terminal command basically. If you need detailed instructions do let me know though.

thanks !
I fiddled with the scripts and made them worked.
for my case, I changed this part "/usr/local/bin/" to "/usr/local/opt/ruby/lib/ruby/gems/2.7.0/" (bc that is where istats was located) for all three CPU / GPU / Fans.
So now all works !!

then I tried the "Add your game to GameMode" button on the Touch Bar. It shows up the help menu on customisation. I put AQT back to Master preset (I have another preset with one customisation for 2-finger swipping left in finder to go to previous folder)., thinking it would remember to launch automatically GameMode when this app is launched. It did not work.
Any help on this "add your game to GameMode" please : I may have misunderstood the purpose of it. If so, is it possible to make launch gamemode automatically for specific app ?
thanks !

1 Like

Nice job getting it working! I'll probably refer to your process if other people have trouble.

Adding your own game is a manual process and that manual was supposed to walk you through adding touchbar buttons for your games. I admit the instructions may not be the clearest but should be a good starting point

Configure Automatic GameMode

Making gamemode automatically open up seems to be possible, however these changes will be lost if you update AQT.

Add your game to GameMode's conditions

You should see gamemode appear when you have the game frontmost, but it'll most likley be mixed with the QuickStrip.

Exclude your game from the QuickStrip's Conditions

You might need to exclude it from the gesture bar in the same way as the previous image too.

Hi Yuuiko
thanks !
Sorry for the late reply I missed your answer. Thought I was going to receive a email notification for your answer... anyway my bad !

yes I got totally confused on the help page that popped up, did not know what to do. Understood the concept behind it bc I have read the FAQ when I installed the preset.
Reflecting back on it, I could have thought of adding an app in the list and duplicate the actions from a simpler app and change/add rules to add the "game mode enable" ! I can say that now after struggling finding the menus and better understanding how bettertouchtool, the customisation and the preset work ..

Anyway back to topic, it works ! game mode is getting enabled automatically when the game app is launched ! that's great ! thanks Yuuiko

I think I have messed up the master preset / customisations stuff, so lets see what happened at the next update. Maybe I will need to re-do some of the stuff but should be quick now

Thanks again ! super helpful !

I will now go onto the YouTube widget thread page !

1 Like


I followed up the instructions displayed on the Touch Bar, and after installing Xcode and istats, I came across this error while testing the installation :

denis@MacBook-Pro-de-Denis ~ % iStats
Traceback (most recent call last):
7: from /usr/local/bin/iStats:23:in <main>' 6: from /usr/local/bin/iStats:23:in load'
5: from /Library/Ruby/Gems/2.6.0/gems/iStats-1.6.1/bin/istats:6:in <top (required)>' 4: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in require'
3: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in require' 2: from /Library/Ruby/Gems/2.6.0/gems/iStats-1.6.1/lib/iStats.rb:2:in <top (required)>'
1: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in require' /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in require': dlopen(/Library/Ruby/Gems/2.6.0/gems/iStats-1.6.1/lib/osx_stats.bundle, 0x0009): missing compatible arch in /Library/Ruby/Gems/2.6.0/gems/iStats-1.6.1/lib/osx_stats.bundle - /Library/Ruby/Gems/2.6.0/gems/iStats-1.6.1/lib/osx_stats.bundle (LoadError)

Do you know where the issue could come from ?


Are you running an M1 MacBook? I've heard that iStats isn't supported on M1 yet

You're on a M1 device. iStats doesn't work for us yet. I found this out the other day.

Yes exactly, brand new MBP M1 !
Ok that explains the error message then :slight_smile:

Imprint | Privacy Policy