AppleScript does not run

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
AppleScript does not run with keyboard shortcut. In BTT, clicking "Run Script" works perfectly, but using the corresponding keyboard shortcut does not trigger the AppleScript. To make sure the keyboard shortcut is even triggering, I added a HUD overlay showing "test" (which does show up so the keyboard shortcut itself works).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Keyboard shortcut

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro 2016
  • macOS version: 12.6.4
  • BetterTouchTool version: 4.070

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

I'm seeing the same behavior for "Execute Shell Script" on a Menubar item. Clicking the menu bar item previously executed the script but some time in the last couple months, it stopped working. The script still runs successfully with "Run script now"

There doesn't seem to be a general problem with scripts. Most users are running some scripts inside of BTT.

Could you check whether activity monitor shows the BTT script runner processes on your system? (search for script runner)

To test terminal command execution I usually use something simple like "say "hello", if that runs any other script will run if the paths and environment is provided correctly.

For Apple Scripts it is more complicated because macOS only executes one Apple Script at a time. If for some reason a previous Apple Script has not finished, it might block execution for others.
In blocking Apple Scripts you should also avoid to call "tell application "BetterTouchTool" because that could cause a dead lock in some situations. Have you tried to run your Apple Script with the "async in background" version?

I confirmed that both BetterTouchToolAppleScriptRunner and BetterTouchToolShellScriptRunner processes are running on my machine.

have you tried a simple script/command like „say hello“?

set myButton to "Todoist"

tell application "System Events"
tell process "Safari"
click ((UI elements of group 3 of toolbar 1 of window 1) whose description is myButton)
end tell
end tell

tell application "BetterTouchTool" to display_notification "test"

이렇게 다시 붙여넣어서 실행해보세요