App specific trigger setting doesn't work - especially in Fusion360 and Safari

I'm using BTT version 4.062 on MacOS 12.6.3 on a MacBook Pro 14" M1 Pro.

My goal is using a trigger to let the Fusion360 (3D design app) to recognise my Magic Mouse click (Left + Right) as a middle button click. This works as intended when I set the trigger in "All Apps" tap.

However, this creates inconvenience when I use Safari for web searching with multiple tabs open. Safari takes a middle click as a "tab close" command and when accidentally click a safari tab while my two fingers are lightly touching the Magic Mouse without me realising, it closes the tab that I was clicking to open.

In order to prevent this, I tried few method as below;

  • I tried to set the gesture (Magic Mouse click "left+right") in Fusion360 app only: this only works partially. When the trigger is set in Fusion360 app, it takes the Magic Mouse click (left+right) as a middle button click to navigate the screen, however, when I combine the click with "Shift" key to orbit the 3D model, it does not take the click as a middle click anymore. This same combination works without a problem when the trigger is set in All Apps tab but not in Fusion 360 tab.

  • After trying a few different ways, it seemed like the trigger was only recognised properly when it's in the "All Apps" tab. So I tried to disable the trigger in Safari app, however, this was not available.

  • I copied the trigger in Safari app tab. and unchecked the "Gesture is enabled" but it was still working when I tried on Safari tabs.

  • In, All Apps tab, in the specific trigger for middle button that I have set up, I went to Advanced setting - Advanced conditions and added a condition "visible_window_list" to contain "Fusion 360". The BTT showed it recognises whether the Fusion 360 is on the screen or not. However, the trigger was still enabled when the Fusion 360 app is not visible.

Question: How do I disable a trigger in a specific app? Or how do I enable a trigger in a specific app?
Is there any step I miss or something is not working?