App-Specific touch bar intermittently vanishing in 2.687 UPDATE: When command key pressed


#1

Describe the bug
All my app specific touch bars seem to intermittently go way. Switching away from and back to the app fixes the issue temporarily, but then it goes away again

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
TouchBar

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro 13" late 2016
  • macOS version: High Sierra 10.14.2
  • BetterTouchTool version: 2.687

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.


#2

Do you maybe have some trigger that has the "Toggle BetterTouchTool Touch Bar" action assigned that gets triggered accidentally?

I haven't observed similar behavior yet.

Is this happening in a specific app or in multiple apps?


#3

I have no triggers of any kind that toggle that behavior that I know of.

I've seen it most with Visual Studio Code, but I have also seen it in other apps (Tweetbot). I'm reasonably positive it started in the last release.

I have yet to isolate what causes the touch bar to go away, but I've been trying.


#4

Okay, I've figured out the trigger here -- pressing the command key causes the app-specific Touch Bar to go away. Triggering the commands from the menu doesn't cause me to lose the bar, so clearly something is happening when I press the command key (in a key combination or by itself).

What I'm not sure is why, I can't find a BTT setting that would do this, and I can't find another program that might be conflicting somehow. Any ideas?


#5

There are multiple settings that could cause this.
Do you maybe have a key set to disable BTT?


#6

I do not. As far as I know, I have no settings anywhere that would turn BTT off.


#7

Interestingly, when I check the cmd box there, when I press the cmd key, the Touch Bar goes away, but then when I let go of the key, it actually comes back.


#8

If possible, could you go to the about tab in BTT and click the "Export Debug Information" button? This will create a folder called BetterTouchToolDebug, with that I can probably tell you what's going on.


#9

Here it is. By the way, other modifier keys also seem to drop the touch bar. I'm assuming I did something weird, but I can't see what.BetterTouchToolDebug.zip (88.9 KB)


#11

Your setup seems to be fine, I can not reproduce the issue here.
Could you try whether this has maybe be fixed already in one of the newer alpha versions? (Current v2.694)


#12

Does not fix it, presumably something else is interfering, which I had any idea what.


#13

very weird. Does it always hide when you press cmd? Or just sometimes?


#14

Nearly Always. The BTT button in the system part of the bar will bring it back, but I have to press it twice. Leaving the app and coming back will bring it back. And then sometimes it will stay a while.


#15

Really weird.
Can you think of any other touch bar related app you have installed?

Unfortunately I haven't had any similar reports yet and your setup looks really ok ;-(


#16

I experienced the same (or similar) issue. In my case the app specific toolbar vanishes when I press command, option, control, fn or shift key. It's happens every time and I don't have any other touch bar software installed.

  • Type of Mac: MacBook Pro 15" 2016
  • macOS: Mojave 10.14.2
  • BTT 2.697

This started happening recently, but I can't recall the exact moment - maybe in a week or two. Is it possible that the MacOS 10.14.2 broke it (as I installed it on 2nd of Jan)?


#17

No, in general 10.14.2 works fine.

It may be some system setting, but I have no idea what kind of setting.
But maybe also send me your debug info - possibly I can find similarities between yours and @noelrappins


You can send it to andreas@folivora.ai


#18

I don't think I saw this in any of the release notes, but one of the recent alphas seems to have fixed this.


#19

ah perfect, I rewrote the whole code that handles this so maybe I unknowingly fixed it :slight_smile: