App not responding, blocks activity monitor and terminal process list, can't find PID to kill it

Describe the bug
I've encountered a very strange situation.
I've just migrated to an Apple M1 Pro and BTT has been crashing frequently.
I lose my gestures and when I hover the mouse over the icon in the menu bar I see the spinning circle.
The most serious problem is that if I try to launch the Activity Monitor to kill BTT, it just hangs. Even more surprisingly, if I open the terminal to list the processes to kill it, the process list also hangs indefinitely.
I have to restart my mac to regain the functionality and restarting takes a long time probably because the system tries to wait for BTT to gracefully quit.

I though this would be just due to me using an older version but I upgraded today and it just happened again
I'd love to give more details but don't really know how to do that since the app never really crashes and I can't even inspect the process. If you can tell me where to get any sort of logs I'll be happy to help.

The features I use are:

  • gestures for the magic mouse and snapping of windows.

Haven't really found a pattern of any specific action that triggers the issue.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Magic Mouse

nothing relevant

Device information:

  • Type of Mac: Apple M1 Pro
  • macOS version: 12.0.1
  • BetterTouchTool version: 3.626

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
don't have any stack trace

Just happened again. Noticed that I missing gestures when coming back from sleep.
Would really appreciate at least a suggestion of any workaround to kill the process so I don't have to restart every time this happens.
I've worked with unix machines for a long time and I've never seen a situation where a program crashing prevents you from using ps to list the processes and kill it.
By the way, tried guessing the process name and did a killall bettertouchtool but that hangs as well possibly because killall suffers from the same issue as ps

unfortunately I have no idea :-/
This sounds like some sort of macOS bug, because no app should be able to get around killall.

If it happens again, try to run this terminal command:
sample BetterTouchTool -file ~/Desktop/BTTSample.txt

Maybe this can help to show why it's hanging. (it will create a file on your desktop, that you can send to me)

I hadn't restarted since it last occurred so I just tried this but sample hangs as well. Not only do all these processes hang but Ctrl+C doesn't terminate them.
This is really strange…
Any way to have BTT feature on the list of apps on the Command+Option+Esc so next time I can try force quitting through that list?

Very weird, I have never seen such behavior :frowning:. Maybe opening the macOS console app and starting the log stream before running one of the terminal commands could give some hint on what's going on.

I think only apps with a Dock icon show in cmd+opt+esc, you can activate that in the BTT settings:

Thanks for the suggestion, I will activate it to see if I can force quit it that way next time.

The Console doesn't show anything interesting for Terminal or BTT. For BTT I see this but doesn't seem relevant:

Invalidating assertion 413-389-4843 (target:[app<>:731]) from originator [daemon<>:389] [app<>:731] Ignoring jetsam update because this process is not memory-managed [app<>:731] Ignoring suspend because this process is not lifecycle managed [app<>:731] Ignoring suspend because this process is not lifecycle managed [app<>:731] Ignoring GPU update because this process is not GPU managed Calculated state for app<>: running-active (role: UserInteractive)

Restarting now to activate the Dock option.

I'll update this if I gather any new information.