Another 'simple' Drag & Drop thread

Drag and drop should be simple, right? But I'm lost as to what I'm doing wrong.

All I want to do is drag selected files from Finder into an ID3 tagging app called Yate. I've looked at documentation, searched the forum and tried so many different approaches, but just cannot get it to work.

My keyboard shortcut successfully does the following...

  1. Set Finder view to '1' (as icons)
  2. Select all
  3. Move mouse pointer to position over first file in the folder

What it is NOT doing is...

  • Left down click and hold on the first file (ie: prepare to move all selected files
  • Move mouse pointer to position over Yate's File List Panel (the alternating white/grey rows)
  • Left up click (ie: release the mouse button, thus dropping files into Yate)

My starting point is Yate in the top of the screen, Finder below. Finder is layed out as columns. I've included a visual of my BTT actions for troubleshooting. Obviously BTT window is not open when running the actions

This is as far as the actions go. Drag and drop isn't working. Note the 3s delays are inserted whilst developing the actions. They'll be reduced to milliseconds or removed entirely once this is working.

Environment:
MacBook Pro, Retina, 15inch, Late 2013. OS X 10.13.6, NVIDIA GeForce GT 750M 2048MB

Unfortunately BTT currently doesn't have the ability to create mouse drag events (just moving the mouse is not enough unfortunately). You could maybe use Apple's automator and record what you want to do - you can then execute that automator workflow with BTT.

Apple Script can also work and Apples Script Editor also allows to record your actions and replay them.

Thanks Andreas. Could you please assume I know nothing.

I have searched documentation > https://docs.bettertouchtool.net/?q=automator < which gives 15 results. None are an obvious HOW to action a service created in Automator.

I've also searched documentation for 'service', with zero results.

Forum search > https://community.folivora.ai/search?q=service < no results that show and obvious HOW :frowning:

btw, Applescript has a 'record' function, but it doesn't seem to record mouse actions

Can someone please help?

Automator and Apple Script Editor are Apple tools independent of BTT. BTT can just trigger the resulting workflow / scripts.

However I think this might be too complicated for what you try to achieve.
Maybe at some point I can add a "Drag mouse to position" action. I'll be looking into that.

I know they are independent of BTT. But you have the functionality of launching scripts from them. I'm asking how to do that as your documentation is not clear. Please help

There are predefined actions "Run Apple Script" and "Start Automator Workflow" to launch these

(I'm trying to add the drag option to BTT right now, so maybe I can have that in the next alpha)

1 Like

In 3.367 alpha, which will be available in a few minutes you can choose "Drag Mouse" as move type:

So just changing that in your action sequence should make it work.

Thanks! BTW, I've found something really peculiar in the way BTT is processing Automator workflows. I'll start a new thread about it, as it'll go off piste here, but long story short BTT actions it's own internal action before an Automator workflow (AW), even if the AW is at the top of the action list.

I'm now going to install 3.367 Alpha and try to ditch the Automator

So here's my BTT workflow...

First 6 actions work fine. Finder is switching to Icons view, select all, position mouse. All good so far.

Whether the 'Custom Click: Left (Down)' works, I cannot tell. 'Drag' has brought about this behaviour...

Note that I'm only dragging to the grey/white rows in the middle of the screen. Not going anywhere near a snap area

I know they are independent of BTT. But you have the functionality of launching scripts from them. I'm asking how to do that as your documentation is not clear. Please help

To help other users, the following sources were useful...

Using Automator: https://www.youtube.com/watch?v=x3dxfpQ8KGY
(Note: ignore MurGaaRecorder.app - It WILL record drag & drop, but save, close, reopen and recall the saved macro does not seem to work. I certainly couldn't activate the MGR recorded macro with BTT. The steps given for Automater were useful though!)

Start Automator Workflow: https://apple.stackexchange.com/questions/47059/accessing-library-in-open-save-dialogs
(Note: When using the Start Automator Workflow action, the folder where OS X saves these workflows is not visible in the Open dialogue. Cmd+Shift+G when the Open dialogue is open will trigger the native 'Go To Folder' window. You'll need to go to /Users/[YOUR OWN HOME FOLDER GOES HERE]/Library/Services/ )

In 3.368 alpha I have added a "Start Mouse Drag" and "Stop Mouse Drag" action, which should also work in Finder and allows to get rid of the "Mouse Down" and "mouse up" actions.

1 Like

Nice touches! Certainly a more elegant way of creating the workflow. Sadly drag and drop still isn't working for me :cry: :

On a positive note for my personal workflow, the developer of Yate has created a couple of .plist scripts that enable loading of folders from within the Yate app. Triggering this feature with BTT, combined with the other macros you helped me with the other day, and I'm able to cross-reference digital audio files with Discogs at a rate of 1 album in 36 seconds! I used to aim to tag 10 albums PER DAY.

Drag and drop is still needed, given the times it crops up in the forum. But I'm happy that I can crack-on without for now. Thanks!

Weird, drag and drop now seems to work for all of my test cases (moving files in Finder, moving tabs in Google Chrome, moving windows). However I have only tested on 10.15 so far, maybe there is different behavior on previous macOS versions :-/

After more testing, in some cases the left mouse down and up are still necessary, but like this it worked on all macOS versions I tried:

image

After searching, MacOS has the feature within. https://support.apple.com/en-us/HT204609

Great solution if you have a Force Touch trackpad

Imprint | Privacy Policy