Airplay Issue on Apple TV4K

I have an Apple TV 4k and a MacBook Pro 2017 with Touch Bar.

Whenever I have BTT running and I click airplay, it's just a black screen on my TV, with the sound working.

When I quit BTT, Airplay works normally again.

Is this a known issue? I searched around but didn't find much.

Thanks :slight_smile:

I don't think BTT can influence this at all unless you have some very specific scripts running in BTT that would somehow break this. Are you sure the black screen was not just a coincidence? I'm using Airplay all the time :wink:

Definitely not a coincidence :slight_smile: I've tried it multiple times. As soon as I quit BTT, Airplay works again. Interesting one, huh?

This is all I have configured:

Weird. Have you tried to restart your Mac? BTT doesn't interact with Airplay at all, so really no idea what could be causing this :-/

I also own the 4k AppleTV and am using it with macOS 10.14

I've found the issue. As soon as I removed the Airplay button from my touch bar, Airplay works fine.

Any recommendations being able to have this button and Airplay working?


Was your button some sort of Script Widget? A normal button doesn't do anything unless it's pressed.

Nope, just a normal touch bar button with the 'enable airplay mirroring' action assigned (as shown in the screenshot) :slight_smile:

So when I press it, it activates airplay but with a black screen. That one button seems to completely stop airplay from mirroring my screen. As long as that button is on my touchbar, Airplay does not display the screen at all.

As soon as I remove the button, airplay works perfectly.

Weird one :confused: