After wake from sleep, version expired and no gestures despite 2.660

Describe the bug
Installed BetterTouchTool 2.660 last night before bed on brand new MacBook Pro 15", computer went to sleep overnight, woke up this morning and gotten the "Version expired, gestures disabled" notice. Tried uninstalling, restarting and more but nothing worked and now I keep having the expired version and no touch bar.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar

I've found this issue around the internet before and I saw a blog post about a similar issue in september 2015. This issue doesn't look different, except for version being 2.660

Device information:

  • Type of Mac: Macbook Pro 15" 2018 (literally just bought)
  • macOS version: 10.14.2
  • BetterTouchTool version: 2.660

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Got this bug too.I have a trial version.


sorry I forgot to provide the new update in time (versions without installed license always expire after a few months) : -)

You should now be able to update.