"Add New Space to Mission Control" keyboard shortcut does not work on portrait monitors.

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

I have already restarted my system and this did not fix the issue. I checked for a newer (alpha) version of BTT but I was already on the newest version (v3.149)

Describe the bug
I have Assigned Ctrl + T to "Add New Space to Mission Control", when using this command on my landscape monitor, it works perfectly, when using it on my portrait monitor, it does not work. It activates Mission Control and moves the mouse cursor, but the cursor moves to the incorrect position. It moves to the correct x position but the y position is too low. The y position seems to be the correct place for opening a new space on my landscape monitor. The mouse cursor also restores it's old position occasionally but not always.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Pro 13", Mid 2018, 4 TB3 Ports + IBM Model M Keyboard + LG 27UL850-W Monitors (Portrait)

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)
I made a short screen recording to explain the issue, unfortunately it does not show up all that well. If you squint, you can just barely make out that the cursor moves to the top right, mission control gets activated, then, after several seconds, the cursor returns to its original position, and mission control is dismissed.
Device information:

  • Type of Mac: MacBook Pro 13", Mid 2018
  • macOS version: MacOS Catalina Public Beta 2 (v19A501i)
  • BetterTouchTool version: (please post the exact version - not just "the latest one"): MacOS Catalina Public Beta 2 (v19A501i)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):