Action Sequence with multiple snap area triggers only fires last trigger

• Action sequence including apple script and more than one snap to window action only fires the last snap to window command.

• I can fire individually and they work

• I separated each into their own named trigger and it still happens

please see the screenshot. If I tried to run both of those triggers with a single keypress sequence and a delay in between them it only fires the last snap to window command.

Model Name: MacBook Pro
Model Identifier: MacBookPro14,3
Processor Name: Quad-Core Intel Core i7
Processor Speed: 3.1 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Hyper-Threading Technology: Enabled
Memory: 16 GB

version: 10.15.3 (19D76)

I can confirm this. I just came in here to report the same and found your post after a search. In fact I can't get a snap area to trigger if there is ANYTHING following it in the sequence. II tried moving the other snap areas I wanted to do into named triggers and then firing these after the first snap are in the sequence but this didn't work either.