Acrobat Not Accepting BTT Keyboard Shortcuts

I have used BTT to remap keyboard shortcuts for Acrobat for a while, for example, Control-S instead of Command-0 for "Zoom to Page Level". In the past few weeks or so, BTT does not seem to work with Acrobat any more. I tried to use AppleScript/Menubar Menu-Item instead of keyboard shortcuts, but it still does not work. Acrobat is still accepting its native keyboard shortcuts, so it appears that it is just not recognizing the BTT keyboard shortcuts specifically configured for "Acrobat Pro DC". Global BTT keyboard shortcuts for "All Apps" still works.

I am on an M1 machine right now, but I am pretty sure the same bug applies to another Intel machine. I have not changed any settings lately.

BTT version 3.951 (2116)
Acrobat version 2022.003.20281
macOS version 13.0.1

I suspect that either Adobe has changed the identifier of the Acrobat Pro (in that case delete it from BTT and add it again), or you accidentally disabled BTT for Acrobat Pro

The problem is solved by deleting and adding Acrobat back to BTT. Thanks!