Accessibilty permission prompt no matter what I do

Describe the bug

Getting a prompt saying that accessibility permission are not enabled for better touch tool. It is on though. Tried turning it off an on. Tried removing the better touch tool entry and manually putting it back. Tried restarting (multiple times this has been happening for weeks now). Tried resetting accessibility permissions in terminal ("sudo tccutil reset Accessibility"). Nothing works. Only thing that works is restarting better touch tool from menu bar. All features have continued to work all the time though so I suspect it's a false alarm.

Device information:

  • Type Macbook Air M1:
  • macOS Sonoma 14.4
  • BetterTouchTool version: 4.460 Alpha (btw is there no way automatically install alphas in the background?)

unfortunately that usually means the tcc database is corrupted. The problem with that is that this database is highly secured and can’t easily be reset without a macOS reinstall. (it‘s possible but really complicated)

Your best bet is to run

sudo tccutil reset All com.hegenberg.BetterTouchTool

while BTT is quit.

You can try running
defaults write com.hegenberg.BetterTouchTool BTTDisableAcccessibilityCheck YES
but that won't solve the issue, might just hide it and will almost certainly lead to untraceable issues.

Worked like a charm thank you! (sudo tccutil reset All com.hegenberg.BetterTouchTool)