Accessibility API Permissions window

I'm getting this window, which is persistent. I can't figure out how to get rid of it. Am on 2.686 (991) on OSX 10.11.6 and have tried a couple older versions, but it still pops up.

Any thoughts?

WW

I'm getting the same as well, FYI.

did you follow the instructions to enable BTT in system preferences -> Security and Privacy ->Privacy -> Accessibility?

Yes, 3 times now. It seems that the System Preference might not be taking that choice?

possibly try to reset the macOS accessibility database using this terminal command :
tccutil reset Accessibility

Done. Will watch what happens. Thank you.

Hello @Andreas_Hegenberg, I just bought the lifetime license, hoping it would solve my issue, naively. Still I love your product so I should have boughten it. Anyways, Im dealing with the same issue: API BTT Permissions prompt... I go there and unlock and add BTT as an application to control the computer but it doesn't show up once I select and try to add it. The permissions list remains blank. I also just tried to use your script and response was "Failed to Reset Database"...

BTT has been working for me for years until I just had to swap out hard drives and rebuild my computer. Currently on a 2015 imac, running 10.13.06 High Sierra, and BTT 2.428.

Edit: Just updated to 3.333 and the problem is still happening.

Most likely a file permission issue. Did you restore your mac from a backup?

Try this terminal command:
tccutil reset All com.hegenberg.BetterTouchTool

If that doesn’t help try to delete the ~/Library/Preferences/com.hegenberg.BetterTouchTool.plist file

And if that doesn’t help try to repair your file permissions:

1 Like

This has happened to me a few times now on the same computer (over the course of a few months, it's happened maybe 3 times).

@Andreas_Hegenberg thank you for this amazing tool! If it were up to me Apple would make you their VP of UX and Sherlock everything in BTT (assuming you'd be okay with that).

(problem solved. Thanks Andreas for Apps & your support!
(This is just as info and documentation for future users having this prob with BetterSnapTool)

I just had the same accessibility bug with BetterSnapTool.

Changed from "Touch" to "Snap" and the tccutil command fixed it:

tccutil reset All com.hegenberg.BetterSnapTool

PS.: Tried a lot before incl. "removing with AppCleaner" ... no success ... only the tccutil worked for me

1 Like