4 Finger Swipe Left/Right to Move Left/Right a Space doesn't work

I've tried with alpha and stable version no crash but in vain.

Describe the bug
I configured

  1. "4 Finger Swipe Left" with action "Move Left a Space" and
  2. "4 Finger Swipe Right" with action "Move Right a Space"
    in "All Apps" session.

I expect

  1. "4 Finger Swipe Left" to swipe "Left"
  2. "4 Finger Swipe Right" to swipe "Right"

It turns out

  1. In stable version, both "4 Finger Swipe Left" and "4 Finger Swipe Right" swipe "Right".
  2. In alpha version, both "4 Finger Swipe Left" and "4 Finger Swipe Right" swipe "Left".

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Trackpad

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook Pro (M1 Max)
  • macOS version: 14-inch, 2021
  • BetterTouchTool version: 4.075(2291)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Sounds like maybe something is wrong with your space switch shortcuts in system settings => keyboard => shortcuts => mission control => mission control

Maybe they have both the same shortcut assigned

Hi @Andreas_Hegenberg ,

Thank you for your prompt reply.
I set "Cmd+Up" to "Mission Control".
Just tried disable/re-enable/re-disable "Mission Control" but in vain.

Attached is my Keyboard shortcut settings, please have a look.

Thanks again,

can you expand the mission control shortcuts in the screenshot?

Wow, you've found the bug.
Both "4 Finger Swipe Left/Right" filling the same key and causing conflict.

It's reproducible.
Keep BTT config
Uncheck Mission Control group
Swipe left/right
It works once
Swipe left/right again
Conflict occurs

Hi @Andreas_Hegenberg ,

May I confirm my case is valid, when and will it be fixed please?

Many thanks,

You should set two different shortcuts for the actions in system settings. Then it should work.

Since you opted to put the MacBook Size and Release Year instead of the "macOS version" I'm just taking a guess here..

If you have MacOS Venture..
you should check under TrackPad settings, and make sure that "Swipe between Full Screen Apps" is not enabled. This uses the 4 Finger Swipe Left/Right Gestures

Screenshot 2023-05-05 at 2.22.10 AM

Hi @Small ,

Thanks for your reply.
My MacOS version is 13.3.1 (a) (22E772610a).
"Swipe between Full Screen Apps" had been disabled when I hit this bug.
The workaround is manually set the correct key to these 2 shortcuts and it now works in Alpha version.