3-Finger-Left/-Right swipe works only once on Mojave

On a MacBook Pro 15" with the final version of Mojave and BTT version 2.641 (that seems to be the last one).
I have set the 3-finger-left/-right sweep on the trackpad to move to the previous/next desktop. Works ok in pre-Mojave. In Mojave, it works once, then the BTT icon in the menu bar is greyed out and the gesture stops working. Have already removed BTT from system preferences and added, which solved its startup problems.

  • Type of Mac: Mac Book Pro 15" Retina, Mid 2012
  • macOS version: 10.14
  • BetterTouchTool version: 2.641

if the BTT icon is greyed out, it usually means that BTT is disabled.
Could you check what is shown in the menubar menu when this happens?

Possibly you accidentally disabled BTT for Finder

I'm not sure if I understand you correctly. If I click on the greyed out BTT icon in the menu bar, I get the exact same menu as when clicking on a black BTT icon.

I've uploaded a screenshot of this greyed out menu situation.
Finder commands like Cmd-Shift-G work also in this desktop.
To make it clearer: I am in desktop #1 with a black BTT icon in the menubar, do a three finger right sweep and arrive in desktop #2. There, the BTT icon is greyed out and I can't move back with the three finger left sweep.
Clicking on this grey icon and "Preferences" opens the BTT preference settings (and shows a BTT icon in the dock). After dismissing this dialog, the menu bar icon returns to black and the icon in the dock disappears again.

I meant what appears when hovering the "Disable BTT for ..." item in the menu. Does it look the same as in my screenshot, or does it show something like "Enable BTT for current app"?

I don't see a screenshot, but anyway: The Disable BTT for... hover says
"Disable for all apps"
"Enable for active app (Finder)"

That's different from the situation in the "black icon" case, where the second entry reads "Disable for active app (Firefox)" (the first one is the same)

The same thing (greyed out icon) happens when I click on the desktop in the "black icon" desktop. That makes Finder the foreground app, and apparently deactivates BTT.

If you click "Enable for active app (Finder)" your issue should be fixed.

Indeed. That was fast. I had the gestures saved in the "Global" part of the settings - should they rather be moved to "Finder"?

Nope all good now!
You probably accidentally disabled BTT for Finder in an earlier version, but this didn't have any effect until now due to a bug that was recently fixed :slight_smile:

Ah just to clarify:
Desktop belongs to Finder, thus if BTT is disabled for Finder, switching to an empty desktop will disable BTT, therefore the gestures won't work anymore.