2 finger tap has a delay after tapping on magic mouse (solved)

I wanted to use either right click or middle click by using a 2 finger tap. They both work, but when I tap with 2 fingers, it takes about 1 second before the right or middle click actually occurs. For example if middle clicking on a link in my browser, it will take a second or two before a new tab in my browser opens (this is not a browser issue, it occurs anywhere and with right click as well even in apps like finder, the right click menu takes 1 second or so to open up). It might not sound like alot, but it makes the process feel clunky and not fluid.

do also have a two finger double-tap configured? (in that case BTT needs to wait to see whether the double-tap occurs)

1 Like

this worked! I actually didn't have two finger double tap enabled, it was configured but not enabled (ie: gesture is enabled was unchecked). But I deleted it anyway and both middle click and right click are working now instantly :slight_smile: thank you :slight_smile:

I‘ll fix that, thanks for reporting!

1 Like