"Your BTT Touch Bar is hidden, Click to Show"

For the last month or two, my BTT touch bar disappears often after a long sleep. I know this used to happen a while ago, but I thought it was fixed. I even completely reinstalled BTT from scratch after removing the BTT library files, but the problem continues. Is anyone else having the same issue?

Yes, same here. Sometimes BTT works right away after sleep but most of the time it’s hidden like you’re showing. Until this is fixed a shortcut to have it shown might be useful, but I haven’t figured out yet how to assign a shortcut to this action.

1 Like

There is a predefined action. Enable / disable Touch Bar, or similar.

I was only able to find the "⌘⌥⇧0 - Toggle to and from the system Touch Bar UI" or turn BTT on/off toggle shortcut. Not sure if that will do the trick :sweat_smile:

I've also encountered this issue, and it's becoming quite bothersome as it happens several times a day. This is likely a bug. I hope there's a solution that can be found.

1 Like

same issue here, quite annoying!

@Andreas_Hegenberg, something happened between v120 and v121. I've been testing all the versions below and it does seem v121 is where it first started going bad. Do you remember what changes went into that release?
100: ok
153: bad
125: bad
119: ok
115: ok
114: ok
122: bad
120: ok
121: bad
120 retest: ok

FYI, for the others who are annoyed, you can roll back to v120 like I did.

Thanks for experimenting! However the 4.120 version didn't have any changes even remotely relevant to Touch Bar behavior. I currently don't think this version broke that.

Have you already tried the latest BTT alpha? (4.188)

Ok, I've installed the alpha and I'll let you know.

1 Like

@Andreas_Hegenberg 4.188 alpha still has the issue.

When exactly does this happen on your machine? Only after long sleep? (I haven't been able to reproduce so far)

I left to walk my dog for around an hour and when I came back it was in that state. Doing an Apple->Sleep and then waking doesn’t seem to cause the issue. Are there any debug steps you can think of that could help with debugging this?

@Andreas_Hegenberg , I did some further testing:
1m sleep: no issues
10m sleep: touch bar hidden
5m sleep: Touch Bar hidden
2m sleep: hidden
1m again: ok
90s: hidden
75s: ok
90s: ok
90s: ok
2m: ok
So it seems to be not completely predictable. Question: since BTT knows when the touch bar is not visible:


can you not instead of showing this error just reactivate the touch bar?

unfortunately it's comlicated because there are lots of cases when the touch bar is supposed to be hidden.

I have done some more changes to 4.191 alpha, maybe these help!

The issue is still occurring with 4.191, but when it's happens, now the menu doesn't have the message to tell us it's hidden anymore.

Unfortunately I'm unable to reproduce on any of my Touch Bar machines.

Would be great if you could go to Help => Export Diagnostic Debug Information (after you noticed the issue happening) and send the result to andreas@folivora.ai. Maybe I can see something useful in the log!

1 Like

the issue seems to be resolved with the new alpha update (13"M1 MacBook Pro)

2 Likes

This is also true for the regular version. To make it reappear you have to restart BTT.

this started happening to me too! now I have to restart BTT every time

I had the problem for a few weeks, but it seems to have been solved since version 4.258. Is this also the case for all of you?