x key not working properly when BTT is active

Strange keyboard behaviour when BTT is active:

  1. I can type uppercase X by hitting Shift + x key
  2. I can type lowercase x by hitting Fn + x key
  3. If I hit just the x key, nothing happens

Other keyboard activity involving the x key (such as Cmd + x) is working just fine.

Quitting BTT, the lowercase x works as it should.

MacBook Pro (14-inch, 2021) running macOS Monterey (Version 12.4)
BTT 3.786 (1931), have tried latest (alpha) version, and have restarted system.

Very similar to a bug report from 2019 (Keystroke loss when BTT is active – any keyboard, “w” key - Keystroke loss when BTT is active -- any keyboard, "w" key), which seems to remain unsolved.

Any thoughts?

Best regards,

do you have keyboard shortcuts involving x configured in BTT?

This is embarrassing... I only use BTT for trackpad gestures, so I didn't even think to check keyboard shortcuts. But there it was! Shortcut x, On Down, No Action assigned to the shortcut.

Disabling it - obviously - solved the problem.

Thank you kindly!

Best regards,