'Works on Keyboard With Same Type' shortcuts assigned to 'mouse keyboard' overridden in browser

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

I'm using a Razer Naga Trinity mouse and I've mapped keys on the side of the mouse to act as a second keyboard, the keys on the mouse act as the 1-9 numerals, I've assigned 'Works On Keyboard With The Same Type' on all the mouse shortcuts so that the numerals on my main keyboard (mac magic keyboard) don't trigger the shortcuts I've assigned to the mouse, everything was working great until I noticed that certain parts of my Brave browser override the 'works on keyboard with the same type', in other words, the numerals on my main keyboard trigger the shortcuts assigned to my Razer mouse when, for instance, I am entering my password or trying to assign a new password to an email account.

That felt quite complex to try and explain, so here is another attempt that might be clearer.

On my Razer mouse, which has a numpad on the side, I have assigned the shortcut 'cmd+W' to the 10 button which is actually a 0 numeral.

I then assigned the setting 'Works On Keyboard With The Same Type' to the mouse hosrtcut.

When I go to type in a password into my email account that uses the numeral 0, which I type on my keyboard, it triggers the shortcut assigned to my mouse and the tab shuts.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Mac Mini, Razer Naga Trinity Mouse, Magic Keyboard

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Mac Mini 2018
  • macOS version: 10.15.7
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.743 (1885)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Unfortunately the default keyboard shortcut mode of BTT can not work while in secure input fields - this is a security feature of macOS that prevents any app from reading your passwords.

Unfortunately the keyboard specific shortuts require this, so the only workaround would be to disable the shortcut functionality completely when secure input is active.

You can disable the auto-switch here:

Maybe I can update the code to automatically disable keyboard specific shortcuts while secure input mode is active. I'll look into this.

Thanks for your reply Andreas, I really love this program and it would be flawless to me if this issue could be solved, alternatively, I would suggest a simpler way to activate the 'disable function', so that I could trigger it with a keyboard shortcut or something.