Window Switcher doesn't detect multiple maximized windows of the same application

Describe the bug

I've upgraded to BTT v4 and tried the new "Show Window Switcher for Active App" action. When I maximize multiple windows of the same application on a workspace (using Amethyst), BTT doesn't pick up all of them. For example, I open four maximized Finder windows, and only one is visible in the window switcher. As soon as I put these windows side-by-side, they get picked up correctly.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

I'm using a "Normal Mouse" trigger (Alt + Right-Click) to show the window switcher.

Device information:

  • Type of Mac: MacBook Pro 14" (2021)
  • macOS version: 13.2 (22D49)
  • BetterTouchTool version: 4.0 and 4.001 (alpha)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

It would also be great to have an option to disable the window preview popover and the search bar. I don't need them when switching between windows of the same application. Thanks!

That's weird, do they show up when you maximize them manually?

A quick test creating 4 documents with TextEdit shows that 'Untitled 3' is missed when maximised, it appears in the list when at its default size. 'Untitled', 'Untitled 2' and 'Untitled 4' all worked fine either maximised or smaller.

Just created 10 text documents and full screened them with Window Switcher->5 and only 'Untitled 4' and 'Untitled 10' are now showing in the list.

Closed all those and repeated but now only 3, 6 and 8 appear in the list when full screened. If I move any of those slightly then some of the others reappear in the list! I'm afraid it all seems a bit random.

I think I might have resolved it with 4.002, which should be available in a few minutes.

BTT 4.002 seems to resolve the issue for me. Thank you very much for the instant fix!

That also seems to have fixed the problem with Terminal windows running ssh or su not appearing. Thank you!