[🧯v3.6.5] AquaTouch -- Powerful, Flexible, Contextual. Supports 55+ Apps and Websites.

Thanks for the speedy response!

So I've actually seen that post & tried to follow it to the best of my ability, but I'm still having issues. Firstly when I use the install iStats function in the preset, the terminal says I don't have write permissions, so I went & manually changed that so I could read & write. Now when I try the button in the preset it shows a ton of tracing data & basically says "Permission denied @ rb_sysopen - /Library/Ruby/Gems/2.6.0/cache/sparkr-0.4.1.gem (Errno::EACCES)" & gives me an "While executing gem..." error. Any idea where to go from here? I'm not very fluent with commands/terminal stuff but seems to have something to do with the file directory maybe?

EDIT: Forgot to mention the exact permission denied thing ALSO shows up for iStats & parseconfis-1.0.8.gem.

To get those working basically all you need to worry about is getting the "istats" command working in terminal. AQT uses that command internally and essentially is just a mini terminal display. Once you can get this working, AQT should either connect in a breeze or even automatically.

I'm actually not versed in terminal either ahah, before catalina it was very easy. I only got mine working with pure, and i actually mean pure chance, I don't even know where iStats is installed.

So, iStats is a "gem" coms from a place that's called "ruby".
It seems MacOS uses some gems and code from ruby itself, but in the last catalina update, apple seems to have locked that installation down "because security".

A big help was this article, Have you seen it / tried it?

From it I now understand that we'd need to start our own directory and ruby gem install system instead of just installing to apple's internal OS directory as pre-catalina...

I'm quite busy so maybe have a look at that site and see if you can get something. If not I'll try look into it further, though I'm afraid that my ruby installation would look, if it was in the physical form, like a hacked together patchy mess!

YES! I figured it out. Not sure how I didn't figure this out sooner, but I hadn't seen the terminal stats like that before so I did some searching & all i had to do was type "sudo gem install iStats" & enter my password, then I immediately tried the buttons in the preset again to show the CPU temp etc & it worked immediately. So I think to anyone else having issues, they just need to type that sudo command above & it should work properly if everything else was installed correctly. No need to change any permissions of folders or edit the preset scripts! :smiley:

EDIT: I guess I just didn't have or know how to properly install the iStats gem & where to put the .gem file, but now it appears in the /cache folder where I assumed it would go.

EDIT 2: Now that I have this figured out, how do it make it so Game Mode automatically turns on with a certain game app? For example Minecraft. I looked at another thread where you had screenshots of changing the conditions under GameMode & QuickStrip, but I wasn't sure where to actually put the condition & what parameters to enter. Sorta want it to just appear like the Gesture Bar does but with ONLY Minecraft, of course. :slight_smile:

hi /u/Userwastaken
actually I did on purpose avoid using sudo gem install iStats to avoid messing up with the MacOS Ruby. That's why in the other threat I installed another ruby folder using the homebrew (brew.sh).
But in the end good that it worked for you

I guess you can find the menu Yuuiko is showing to add the game automatically
here is where the menu is. (that's for the gamemode menu - the first step. second step is similar but in the other section - see in the other thread to do the exclusion)

Ah that makes sense.

I've seen where the edit conditions button is, but what do you change once you click on that? It seems like I could easily mess the preset up by doing it wrong so I wanna make sure that I put the right parameters in the right fields & such.

@Userwastaken

@yuuiko bump

Any plans to fix this? Do I need to enable scripts anywhere maybe?

Yes i have plans though i'll be coding blind as I don't have apple music so I'd appreciate if you could help me out. Would you mind if i PM'd you when I get to it? Quite busy with assessments at the moment.

@Future_Face Sorry about that!

Tapping the song name should show a scrubber for Spotify.

Find it in a "Spotify Seek" folder either in the spotify app or QuickStrip Widgets

1 Like

Thanks. I am making my own preset that I might share on the forum. Can I use the scrubber for it?
Thanks

I tried putting this in my preset but it didn't work. is there something im missing?
edit: lol I feel so stupid.. I didn't have 'show in any open Touch Bar group' ticked
thanks. can I use it for my preset?

1 Like

Sure no worries, i'll try record a video as it pops up & then goes again pretty quickly.

1 Like

@Future_Face Sure, you can use it in your preset!
Just maybe not the QuickStrip concept as I'm quite protective of that as AQT's main design feature.

Let's root for this!

1 Like

I dunno what you mean by quick strip. all ive done is copy and paste the slider and the duration on each side. is that fine?
thanks

I meant the persistent four button setup I have on the right, Should be good! Go ahead, can't wait to see your preset!

1 Like

Hi! I was wondering, how do I disable the youtube widget? Or I prefer to be still able to use my 2 or 3 finger gestures even when with youtube open

@kevotsai

You should be able to use gestures on any screen, maybe try start your slide away from any visual duration sliders / scrubbers.

Otherwise, youtube's layout is something that is a choice to open up and can be closed and opened, so try closing it to gesture if the above doesn't work.

I see you have both safari and chrome open.
Lately I realised having both open makes the youtube widget glitch out, try closing one of them.

Also try check if youtube is configured correctly, as theres a BTT bug that can randomly reset this:

Amazing Preset!!!
Thanks for the effort.

Any chance you add an option to switch between keyboard input languages?

cheers!

Imprint | Privacy Policy