Using modifier key caushing crash

Describe the bug

My preset crashed and had been wiped from within preferences displaying 'You have not yet configured actions in BetterTouchTool' so I went ahead and tried restoring from back up but I was getting the same issue. Then I checked for updates in both BTT and the GoldenChaos preset installing both from scratch. It seems to install fine until I click one of the modifier keys such as command/alt which then causes the error to happen again. I have tried updating to the latest alpha version of BTT and the latest preset for golden chaos.

I have also tried running tccutil reset All com.hegenberg.BetterTouchTool in terminal but still nothing, I did notice that when importing a preset the name of it isn't displayed properly. Image posted below.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
TouchBar but does appear to wipe everything from presets.

Screenshots

Device information:
MacBook Pro 15" 2018 touchbar
Catalina 10.15.7
GoldenChaos 3.392
BetterTouchTool 3.506

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
I have no idea how to export the console logs correctly but I have attached an image below, cant upload a text document.

Anybody have ideas, updated to latest alpha but still not working

Imprint | Privacy Policy