Update to 2.645 - All presets missing

Describe the bug

I updated from 2.536 to 2.645. All my presets and widgets have disappeared. Touch Bar displays "You have not yet configured actions in BetterTouchTool". Help!

Device information:

  • Type of Mac: MacBook Pro 2018
  • macOS version: Mojave 10.14
  • BetterTouchTool version: 2.645


There are various backups in ~/Library/Application Support/BetterTouchTool

The latest used database should be named like this:

A backup always consists of these 3 files, you can try to rename the previous ones you had to that 2_645_build_0954

So for example if you have

Try to rename them to (and delete the 2_645 ones first)

Best to create a backup of that folder first.

Thanks for the reply. This worked, with one modification. For your and anyone else's information, here was what helped me.

First, here was my folder and its files:

After backing up the entire folder, I first tried renaming per your example, which did not work. Then I actually went into the Backups folder and unzipped the archive within, which contained a similar set of files. I tried using the ones named as above, which also did not work.

Then I vaguely remembered your instructions here, which gave me the clue to sort by Date Modified, which showed me that the most recent files (after the current ones) were the "btt_data_store.v3".

I renamed those and - aha! It works again!


I am curious why the tiggers disappeared. Is there something I missed or should have done? Was it just a glitch?

If it was a bug, I’m happy to help by sending logs, etc. Let me know.

When updating to a new version BTT, BTT tells the system to create a copy of the data files and rename them for the new version. Then the data is migrated to the new database format (if any changes to the format have happened).

It's hard to tell what caused it, maybe the migration process didn't complete correctly or the file didn't copy successfully.

As I haven't had similar reports lately, I think it was "just" a glitch. The file operations and also the data migration stuff is mostly handled by the system frameworks, which makes it hard to debug.

In case this happens again, please let me know!

I already plan to make this more fail-safe in the future by checking the number of triggers before and after the update, and retry the migration in case it differs.

Got it. Thanks for explanation!

Will let you know if I see this in the future. For now, everything seems good. :slight_smile: