Unexpected window resize when selecting text in Safari

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.
I have two monitors, one is the internal monitor of my MBP, and the other one is a Dell U2718Q, which has higher resolution than the internal one.

I have a maximized Safari Window(Maximized by BTT drag to top) on the external monitor. When I'm browsing the internet and randomly select text on the webpage (my cursor never move out the webpage area, so it should never drag or resize the window), the whole window resizes to the size of my internal monitor. It happens occasionally, by selecting text repeatedly for about 10-20 times, the bug will occur. I tried to switch main display in System Preferences, but it doesn't help.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Mouses and trackpads, regardless internal or external.

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

To make it easier to reproduce, the webpage is https://dn42.net/howto/Bird-communities

Device information:

  • Type of Mac: MacBook Pro 2018
  • macOS version: 10.15.2
  • BetterTouchTool version: (please post the exact version - not just "the latest one")
    Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Having this problem since 10.14.x, so it might not be a new bug of 10.15.

Having the same issue it started after upgrading to Catalina. Looks like it was reported before too:

Same here - very easy to replicate, just snap a safari window to one side, then highlight something and see how the window snaps back to full size.

does this also happen if BTT has the screen capture permissions in system preferences-> security & privacy-> privacy?

That section has no apps listed in my Mac, although I recall having to "approve" BTT and screen permissions (which then you explain won't even be used by BTT, in the install process)

However there are no apps in the section you mention, neither BTT nor others.
I wouldn't even know how to add it, as there is no "add" button or similar in the Mac Settings, I just see that now...

How do I set it?

It should automatically show up there ;-/

You can reset the BTT permission state by running this terminal command:
tccutil reset All com.hegenberg.BetterTouchTool

However please save all unsaved work and quit BTT before doing this - in some situations this freezes macOS.

I did that now and I can tell more details.

  1. BTT says, System Preferences => Security & Privacy => Privacy => Screen Recording - but that's not what opens when you click the blue button in BTT installer. You will instead get System Preferences => Security & Privacy => Privacy => Bedienungshilfe the first time and the second time System Preferences => Security & Privacy => Privacy => Input monitoring.

  2. I checked both those permissions but the System Preferences => Security & Privacy => Privacy => Screen Recording still is showing up empty.

  3. I attached screenshots of each setting as I think there is a misunderstanding about the paths to the menus...

  4. Now the issue still persists

That's very weird, BTT definitely tells macOS to open screen recording :-/ (I just made sure this is still true for the latest BTT alpha)

After clicking continue:

macOS should show this message:

Are you on macOS 10.15.2? (This whole new permission system has been super buggy on 10.15 and 10.15.1 but I felt it got better with 10.15.2....)

I rerun tccutil reset All com.hegenberg.BetterTouchTool, this time it did add the screen permissions but not the input-monitoring permissions as seen in the before screenshots.
Now that one is empty.

Now the issue with the highlighting also seems resolved.

But I have no more permissions in input-monitoring (not sure that even needed...)


Awesome. These input monitoring permissions are not necessary for BTT. It is a bug in macOS that sometimes causes them to be added there. I added a workaround for that in the latest BTT alpha.

1 Like

Tried tccutil reset All com.hegenberg.BetterTouchTool-setapp, but still can't see permission checkbox under screen recording or input monitoring, only Accessibility. I didn't see Screen recording screen from BTT and the macOS permission prompt. Is there a way to trigger that permission manually?

I'm using setapp version so there is no option to update to alpha version. The current version is 3.024 | 1372.

Ah good point with the SetApp identifier. I'll release a new version to Setapp this weekend!

1 Like

Hi, any update on setapp side? Thanks!

1 Like