Unable to save preset in BTT 2 and impossible to manual import in BTT 3

Describe the bug
I have the habit of periodically exporting presets (only one actually) and saving it to an external HD. Since the end of 2017 doing the above mentioned export has become impossible: the interface seems to work normally but no preset file is saved. To work around I usually copy a series of files from ~/Library/Application Support/BetterTouchTool (all the "btt-data_store" files and the "bttdata2" one).

Now there is another problem: after downloading the BTT 3 trial, and overwriting the previous version, the commands are not the same because, inexplicably, there are no recent additions and modifications. Then I tried uninstalling it by deleting everything with "AppCleaner" and copying the trial again in the Applications folder, opening and closing it to let it create the folder in Application Support, finally I've copied the previously mentioned files to the Bettertouchtool folder but it seems that the app is different and old files are not recognized! Everything has been lost (until I have uninstalled everything again to go back to version 2.428)

Is there really no way to export presets? (In December 2017 I changed my Mac, can the problem be caused by the machine?)

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Device information:

  • Type of Mac: iMac 27-inch, 2017 (previous one: iMac 27-inch, mid 2011)
  • macOS version: macOS Mojave 10.14.5
  • BetterTouchTool version: actual version: 2.428, trial version: 3.02

I think there was a bug in an older version that caused export issues with specific trigger setups, but I don't remember which.

You should be able to use the old data files in the new version by renaming them like this:

In this example 3_072 is the version and 1179 the build, you can see both by clicking the BTT menubar icon:


1 Like

OK I'm gonna try your suggestion, but to be more precise these are the files I have saved that I guess correspond to your advice:

As you can see there are files with "v2" extension and files with "v3" one, and I suppose that v2 ones are files for version 2 and v3 ones are new files compatible with version 3, so probably I should use, renaming them, only v3 files, right?
Thank you very much for your support!

They should all be compatible with v3, use the ones that have the newest "last modified" date.

If you are able to get them loaded in the current version you should also be able to use the Manage Presets => Export Preset functionality again to export as JSON.

You can also send them to me, then I'll send you a JSON export (andreas@folivora.ai)

1 Like

Ok I've controlled all the files and the I've found that the ones with the most recent "last modified" date are the v2 files! Probably this is the reason of the initial problem after first usage of BTT 3 version.
Now I've reinstalled it and copied v2 files after renaming as you suggested and now everything is alright, perfect!
The only really strange thing is that Export Preset is still not working, I've also tried to use GZip compress function but nothing has been saved! I will continue coping those files and maybe one day I will try to redo everything manually, I don't know, anyway thanks a lot!!

in that case it would be really great if you'd send me the data files so I can find and fix the export bug!

1 Like