Two finger swipe sends the cursor back to the start of a line, regardless of what it is set to do. This makes the gesture not work if the cursor is over a text input field. If BTT is disabled, the mapped hotkeys work correctly.

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
If BTT is enabled, 2 finger swipe left or right will move the text CURSOR to the front, or end, of the text line, even though it is mapped to just go forward and backwards in Safari (using command-] and command [ ). It will also not move the page forward or backwards with swipe gestures until you click outside of a text input field.

It behaves as though BTT is also sending the OTHER hotkey combo (command arrow forward, command arrow back) as well, since those hot keys also move the cursor, regardless of BTT running or not. But the command - ] hotkey should not have this effect.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Pro 16", Catalina, touchpad

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 2019 MacBook 16"
  • macOS version: Catalina
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.373

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Workaround: I deleted the gestures completely in the "New Configuration UI" and added the back in the "Old Configuration UI". If I add them in New Configuration UI, the bug happens. So only adding the gestures back with the Old Configuration UI makes the gestures work correctly.

Side note: I had imported the presets from a Mac running BTT 2.9xxx, and it appears that when you change a gesture made in the Old Configuration UI, using the New Configuration UI to make the change, it does not actually remove the old mapped keys, it just appends them.