Triggering named trigger via AppleScript makes BTT unresponding if NT contains AppleScript with command for BTT

Describe the bug
I tried to make a named trigger with bunch of refresh_widget commands to launch it from other places. I tried to trigger it via AppleScript and found that it causes the beachball of death on BTT.
It seems like triggering via applesript a named trigger with any AppleScript containing BTT AppleScript API commands leads to such behavior.

below are my test scripts:

tell application "BetterTouchTool"

trigger_named "TEST"

end tell

and script from the trigger:

tell application "BetterTouchTool"

set_string_variable "testVar" to "tested"

return get_string_variable "testVar"

end tell

Device information:

  • Type of Mac: MacBook Pro 16 inch
  • macOS version: 10.15.2
  • BetterTouchTool version:3.225 (1402)

If you don't need the response you can use trigger_named_async_without_response instead - unfortunately currently BTT only allows one level of nesting for synchronous calls inside BTT scripts (it's a limitation of Apple Script, but I have a workaround planned )

Hi, Andreas!
Thanks for the response!
Got it. will try to avoid this by copying the same code many times (meh)