Trackpad gestures stop working when USB device is connected/disconnected

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
When a USB device is connected/disconnected (tried it with both a USB-C monitor and an external mic), BTT trackpad gestures stop working. Keyboard shortcuts and window snapping still work fine. A workaround that I found is to add and delete a trackpad gesture. That'll reactivate all the trackpad gestures until the next time a USB device is connected/disconnected. Note that the gestures still show as enabled in BTT settings, they just don't work when I try to use them. I just bought my Macbook today, so it's very unlikely that it's some kind of hardware issue/software conflict. I am also not getting any kind of notification about a usb device constantly disconnecting.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Trackpad

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: M1 Macbook Air
  • macOS version: 11.2.3
  • BetterTouchTool version: (please post the exact version - not just "the latest one")
    3.561 (1701) - this is an alpha version, but it was also broken on the stable version (can't access the version number anymore)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

most likely your usb device is not getting enough power and constantly disconnecting and reconnecting. In general usb device do only cause a very short interrupt (few milliseconds)

Would that result in behavior where simply adding and deleting a trackpad shortcut reactivates all of the trackpad gestures?

I have previously used BTT with a different macbook and the same monitor without issue, but now this same bug is occurring on both devices.

the fact that this happens when I disconnect the only USB device too makes me think that it's a bug with BTT. im happy to provide logs for debugging though im not sure how to find them

Managed to fix it by creating a new profile with the exact same shortcuts. My old one was imported, perhaps there's an issue with the importing system? I imported and exported from the same version so I don't think it was a version conflict

Imprint | Privacy Policy