Touchpad clicks not always registering with OS

I'm running macOS High Sierra 10.13.4 with BTT 2.517 (856) and I've had an issue for quite a few months now where when running BTT the OS doesn't always register the clicks, yet the BTT live-view shows my inputs. An example can be found here:

I have not uninstalled BTT as I had a few gestures set up that I didn't want to go through the hassle of reconfiguring, and I didn't see a way to export and then import them. I end up closing out BTT because of the frustration, so perhaps I should.

Using AppCleaner I uninstalled BTT version 2.517 (856) and installed the latest stable release ( and the problem persisted. I removed it once again, then installed version BTT 2.09 and I didn't have the same problems. Then went to 2.321 and was fine as well, as was 2.434, and 2.510. I then tried the latest release, 2.515 alpha built yesterday, and it too is working. So, I don't know what happened with the previous install of BTT, but it's working properly now. Shrug.

It looks like I spoke too soon. As soon as I clicked into Preferences to make some new gestures, it started acting up again. I'll have to debug this a bit further.

Usually clicking issues are caused by conflicts with other mouse/trackpad/keyboard related software running on your system. Unfortunately most of the time there is not much you can do but to decide which of the affected apps you want to continue running :frowning:
I think one app that doesn't work well with BTT is Steermouse, but I'm sure there are others.

Thank you for the reply. The only other app I had running that I think might cause conflict is Spectacle but I closed that out and BTT is still acting up. It worked beautifully (alongside Spectacle) for a while up until maybe 2-4 months ago (wish I had a more specific time frame). I haven't been able to run BTT since as it's so frustrating to have to click on things multiple times just for the clicks to register, which sucks because it's a great app as I love having the additional custom gestures available.

I'm reproducing the same problem, I think it happened around 13.3 update, I've waited till 13.5 to see if it would be fixed, and it haven't, the application is totally unusable - I've been using it for years and it simply kills all my workflow (also the bloody new low keyboard).

I'm SE with a lot of experience in linux/mac, I cleared, cleaned, uninstalled, reinstalled everything related to BTT and the problem still exist, even without ANY gestures defined, and even with all the mac native gestures disabled. I don't have any keyboard/mouse related software and the problem exist even when I close those.
The only step I haven't done is factory reset the laptop.

I also have 12.x (Sierra with normal keyboard), and the problem doesn't occurs on that laptop.

If possible go to the about tab in BTT and click the "export debug information" button. This will create a folder called BetterTouchToolDebug on your Desktop. Would be great if you could send that to then I'll look into it, the logs should be showing me why clicks are blocked (if any are actively blocked by BTT, otherwise it's "just" a conflict with some other app).

Ah I just remembered two things:

I once had a user with a broken trackpad that caused such behavior. It constantly produced phantom touches even when he was not touching it. This caused BTT to block clicks in some situations. You can check this in BetterTouchTools "Live View"

One other user with a similar issue had a broken usb or bluetooth device connected to his Mac, which caused the bluetooth stack to reset every few miliseconds also resulting in blocked clicks.

1 Like

Andreas the second one was the issue for me! I could see the clicks registering in the live view so I figured it wasn't my trackpad, but never thought that it could be something to do with my USB stick that's plugged in. I pulled it out and all clicks (and just taps) were working again with BTT running! Plugging the USB stick back in at just the right (or perhaps wrong) spot and it wouldn't work correctly again. I've had issues with this particular USB stick not always showing up once pushed in - the contacts just don't quite contact right on my MacBook (MacBook Pro (Retina, 13-inch, Late 2013)). Anyway, thank you for the response, it was definitely due to USB!

Awesome! I need to remember this.

You should get rid of that stick, because if it was able to cause this behavior it must have pretty much constantly produced errors in the USB/Bluetooth stack. These errors also use significant amounts of processing power.

@Andreas_Hegenberg Thanks, problem solved!

The problem was similar to @dustinfl's - a bad usb network adapter, BTT works perfectly when I disconnect it.