TouchID blocked by BTT

Describe the bug
When a process or app asks for confirmation with the touchID button I have to click the prompt on the screen, not just put my finger on the button.
For sure it is a BetterTouchTool-related problem, because I've done a clean install recently and just after it the touchID worked like it should.
For a test, I created a new user and launched the BTT. TouchID worked well until I've set a first Touch Bar button in the configuration window.
Just after that I came back to the problem.
As you can see on in the screenshots - when the window appears on the screen, the fingerprint is grey, which means that it doesn't look for a finger on touchID button. When I click the window, there is a prompt on the Touch Bar and it accepts the fingerprint.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Pro Touch Bar


Device information:

  • Type of Mac: MacBook Pro 2018 Touch Bar
  • macOS version: 10.14.3
  • BetterTouchTool version: 2.702

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Perhaps it has something to do with system version - I have the same BTT version (2.702) but running on 10.14.2. 1password gets focused without hussle, preferences as well. I have pretty complex setup on my touchbar.

Perhaps you could share you touchbar config, maybe there can be an issue with particular actions?

Hey! Thanks for quick reply.
I've upgraded to 10.14.3 2 days ago, hoping the problem is connected to something else. That's why I've done the clean install.
I'm using 2 configs listed below. They are rather simple, so I don't know what could be connected to the problem.

Default.bttpreset (281.4 KB)

better.bttpreset (102.4 KB)