Touch bar widget: Run Applescript: Widget not showing with saved applescript

Describe the bug
Run Applescript Widget stops working if saved applescript is selected. If same code is put directly widget starts working.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar


putting directly-

widget is visible-

using saved applescript-

widget is not visible-

test-hello.scpt applescript content-
return "hello"

Device information:

  • Type of Mac: MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports, Touch bar)
  • macOS version: High Sierra 10.13.5
  • BetterTouchTool version: 2.548

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Hey @Andreas_Hegenberg, could you check this? All my widgets have stopped working because of this. Most of my applescripts have inter dependencies, so can't put those directly as well.
Please check and let me know the resolution, I could be missing something very basic here.

Should work again in v2.554 alpha

So issue with saved applescript seems resolved, but there is another bigger problem that has popped up now.
Run Apple Script and Show Return Value seems to have stopped working now, so widget never updates the value. My action applescript also returns the same value after executing the action, Widget is updating after that click though.
I tried using default date applescript widget. Although, it seems to be working with default date shell widget.

mh that seems to work fine here, what kind of script are you using? Does the script work when starting it in the Apple Script editor?

I was using normal applescript. Tried using default date applescript widget (as shown in screenshot), it wasn't working with that as well.
Cleaned and reinstalled BTT, started working after that. Not sure what was the problem.

Thanks for the support.

Please let me know in case this happens again! Sounds like a bug somewhere but not sure where :slight_smile:

@Andreas_Hegenberg I am facing the above mentioned problem again. Apparently, applescript widgets are not running on the schedule. I have Execute every x seconds defined as 5.

More context on issue: I have a youtube widget which gets title of open youtube tab and shows in touchbar. On click, it opens that tab and return the title again for widget update. Since widget script is not running on frequency, it never updates with latest title, but when I click on it, it opens that tab and updates the widget at that time.

Let me know if you need sample logs or some other info.

Another point to add:
When this issue happens, Clicking on Run Script in Widget customisation screen doesn't return any result, while running the same script from script editor works.

Screenshots for reference:

Using script editor:

Same with Spotify widget:

Working in Script Editor

mhm, this sounds like your script has hung up for some reason / doesnt respond. However BTT should kill it after ~60 seconds.

Apple Scripts are always executed in sequence, thus if one script blocks, the next runwon't return.

Could you maybe provide your setup to me (here or via then I can check if I can reproduce it.

Don't think there is anything in the script which would hang. Shared the setup on the email.

Started working after 2.618.