Too simple to work?

I am told:

„Setting up key repeat is really simple.“

Just do that.

image

Oh good, then I did exactly that... But it does not work :rofl: Does anyone know how to do it? Thanks :slight_smile:

what are you trying to repeat? For most things it should work exactly like this :slight_smile:

I want the spacebar to not immediately move the cursor to the right when down. So I set up a "Repeat Delay" with "prevent recursive triggers" because BTT crashes without it.

hm, I guess this is a contradiction in itself. I want a repeat delay, but with the same keys not repeating. :joy:

That's the mistake, isn't it? Do you see any other way to do that?

Haha, now it doesn't sound simple anymore :slight_smile:

I think currently the repeat doesn't work with "prevent recursive triggers". I think in general this should be working, I'll need to check why it doesn't.

Letters do not repeat (macOS). If "a" is pressed and held, "a" is output only once. If I want to have that repeated, I have to set up "a" = "a" with a repeat rate. But BTT then crashes. Would be great if this could be done :slight_smile:
Do you understand what I mean?

Letter repeat can be enabled in macOS:

Yes, that was just an example to show the logical problem of Recursivity, or whatever you call it.

What I want is a delay for the spacebar. Repeat when down, but with delay.

I can set this up in macos, but then it also affects keys like enter or backspace. But it should only affect the spacebar.

What Unshaky can do is tap and hold Spacebar twice, the cursor stands still.

Ah, and here a comma (,) is shown.

image

But it does not work with a comma. It needs a fullstop (.) It took me a while to understand that :slight_smile:

I have figured it out. Repeat keys that do not repeat by default.

b = b and BTT crashes
fn b = b, works

Doesn't interest anyone. Could be in the manual anyway. So that nobody has to try for hours like me.

Every trigger that triggers itself crashes BTT until the "prevent recursive trigger" box is checked. The problem is that there is currently a bug where key repeat does not work within BTT if that option is checked. I will fix that soon!

That is not the point. BTT cashed even if "prevent recursive trigger" is not activated. The trick seems to be to use fn. This is obviously not recursive, and leads to the desired result. This also works the other way around. Block keys that repeat by default.

That's what I meant :slight_smile:
It needs "prevent recursive trigger" to not crash, but when that is active repeat does not work right now.

I see, but the explanation is a contradiction. Repetitions should not be allowed, but still work :joy:

The "prevent recursive trigger" is not about repetition, it's about disallowing a shortcut to trigger the action that is assigned to that shortcut in BTT.
It's complicated :wink:

E.g. if you have set A to trigger A in BTT, that would cause an infinite loop and crash immediately without the prevent recursive trigger option. Because triggering A would send A would trigger A would send A would trigger A.......
The prevent recursive trigger option would in this case tell BTT "ignore all A as input trigger after the repeat is started", it can still send A to the system though.

Now I get it :slight_smile: Anyway until this is fixed, the fn trick is very useful. Wenn du das gewusst hast, hättest du das ruhig sagen können :slight_smile:

1 Like

:grinning: leider nicht dran gedacht, dass das für dich relevant sein könnte... nächstes mal :stuck_out_tongue:

Es ist für dich relevant... aber nicht hier, ich schreibe dir morgen eine Mail :slight_smile: