"Toggle Night Shift" not working

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool

I don't know how to install the latest alpha version. I've installed BTT via SetApp.

...and that you have already tried to restart your system :-).

I just tried that, nothing changed.

Describe the bug

I've set up a Keyboard Shortcut for "Magnify Key" to trigger "Toggle Night Shift".
This doesn't seem to work. When I press the key, nothing happens.

The default OS action doesn't happen, because BTT probably intercepts the event and blocks the default action, but "Toggle Night Shift" also doesn't happen.

I tried attaching a different action to the key and that other action executes successfully (I attached "Show BTT preferences").

I also tried to use different key and again, "Show BTT preferences" works as expected, but "Toggle Night Shift" does nothing.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

MacBook Pro built-in keyboard, and Magic Keyboard

Device information:

  • Type of Mac: MacBook Pro (16-inch, 2021) M1 Pro
  • macOS version: 12.1 Monterey
  • BetterTouchTool version: 3.714 (it used to say 3.624 in About BTT, but 3.714 in SetApp, it says 3.714 in both places after I uninstalled and installed it from SetApp again)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

I just bought a new MBP and used Migration Assistant to move all the files from the old MBP to this new one. It could be that file or system permissions got messed up in this process. I didn't install SetApp or BTT anew. Migration Assistant (Apple's software) just copied it over from my old Intel MBP to M1 MBP.

Is there any way I can help you debug this by providing some more info and if so, how?

I also found this other issue that might be related: