Specific settings for current application is broken (BetterSnapTool)

Describe the bug

The 'Specific settings for current application' window doesn't show up anymore for BetterSnapTool. It looks like it's going to (the frontmost app goes to the background) but the BST window never actually appears.

My app-specific settings are all saved (& still work after reinstalling, etc) but I can't edit any b/c the window doesn't show anymore.

I've tried reinstalling BST (from App Store), restarting mac, etc. Tried quitting all other apps. I've tried using BST to center the missing window. Tried security preferences removal. Tried terminal command tccutil reset that you've posted before but says "Failed to reset database".

Clean reinstall (trashing all prefs files, app support files, caches, receipts, etc) doesn't work.

The window isn't hiding behind applications, either.

Two years ago I had my GPU fail on me so I'm running integrated graphics only & had to modify some system settings in order to get the display to work on boot. My screen resolutions were corrupted.

But BST has never given me this issue until recently (a few months)


Device information:

  • Type of Mac: MBP mid-2012
  • macOS version: 10.12.6 (16G29)
  • BetterSnapTool version: 1.9.3

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

BST process sample:
Samples.zip (90.3 KB)