SOLVED Copy cell > tab > Copy cell = Only the last cell content is in the clipboard

Mac 12.2.1
BTT 3.745


Here is an issue that I've an encounter for months always attempted to solve it but always failed.

I'm working a lot with google sheet. Typical workflow involve copying and pasting cells into a CMS system.
So I select a cell, copy it, use tab or arrow to move to the next one, copy it and so on. See a screenshot of what I would like to achieve.

I'm using the BTT clipboard manager.
Process priority helper is active.

The result is that It only copy the first item and the last (sometimes just the last one)

I tried to add delays in between action with no success.

Note that when I'm doing it manually, it worked perfectly. All the items gets into the clipboard and I have a formula to paste them successfully based on their order in the clipboard.

Would love some help to solve this copy issue.


Hello, Uping this post. No one is having a similar issue ?

You probably need to add some delay between these actions. (Predefined action "delay next action")

//edit: ah I just saw you already tried that
//edit2: I might have an idea what causes this. I'm currently building version 3.758 which will be available via "check for alpha version updates" in about 10 minutes, would be great if you could try that one (but you will still need some delays)

1 Like

Problem solved ! It's working now :slight_smile: Thanks a lot

I did some more changes, 3.760 should work without delays. (Again will be online in 10 minutes)

And just for reference in case somebody else stumbles upon this thread: there is now also an action to force a clipboard refresh "Force immediate clipboard check". It's not necessary for this situation, but can be helpful for others.