Since update, BTT trackpad gestures regularly fail

Since the update, all my trackpad gestures will stop working randomly. "Restart BTT" sometimes fixes it, but sometimes a system reset is required to bring them back. This happens multiple times a day. I'm not sure what else to try :confused:

BTT 3.149, OSX 10.14.5, MBP Retina 15-inch Mid 2014

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

I have had this problem too, in my case, 2 finger gestures would go back to MacOS defaults, but the three finger gestures would keep working as I had programmed them.

I reverted back to 2.0 and thing work as they did, and I have no use for any 3.0 features (at the moment), but would like to find a solution too. The developer is very responsive though.

update to BTT >= 3.154 will most likely solve this for you.