Simple Window Manager - SWM

Do you using a big size / 4K monitor? my stage manager automatically hides itself when i maximize window but might work differently
Can you try this;
1 - Open SWM and press P. it will open preset folder
2 - Open COM.js file with an html editor or text edit
3 - Change this line
BTTCareForStageManager:1, to BTTCareForStageManager:0,
and save it. restart bettertouchtool

Also can you try to use resize left half screen action too, it works differently than maximize window

Do you using keyboard shortcut or button on UI for maximize action

let me know if thats what you want

I will add a setting if this one solves your issue

1 Like

thank you for taking the time to try and help me out.

@yw4z SWM v1.0.2 doesn't work well with BTT (v4.394).
BTT crashes with following steps:

  1. Fresh install BTT 4.394.
  2. Import SWM v1.0.2.
  3. Press Fn+W keys to show SWM Popup Window, then cancel it.
  4. Restart BTT from menu bar.
  5. BTT crashed and keep relaunching.

I checked the file ~/Library/Application Support/BetterTouchTool/btt_user_variables.plist and figured out BTT crashes when there is value existed for key SWM-FA.

<dict>
	<key>SWM-FA</key>
	<integer>0</integer>
	<key>SWM-Stg</key>
	<string>{"Version":102,"Gap":0,"GapSize":20,"Distance":50,"POV":1,"PDP":1,"FOV":0,"FOM":0,"Grid":"7x3:8x5:5x6","MXGap":1,"wGestures":1,"Titlebar":1}</string>
</dict>

After I removed the key SWM-FA from plist file, BTT gets back to work.

@skyjia thanks for reporting

hi @Andreas_Hegenberg
maybe it could be general issue not related with latest alphas
also you can read post above. thanks

This one sets SWM-FA variable as string

also i'm using this on code. this is also string beside 0 has no quotes

callBTT('set_persistent_string_variable',{variable_name:'SWM-FA',to:0})

but plist file is integer

<dict>
	<key>SWM-FA</key>
	<integer>0</integer>
</dict>

ah, you are passing a number but using the set_persistent_string_variable function. You should pass the 0 in quotes, as string.

I’ll add some code to handle this. The crash should already be fixed in the latest alpha

@Andreas_Hegenberg thanks. i added quotes. i thought it was automatically converted

@skyjia still do you have that issue on latest alpha

4.396 (uploading now) automatically converts if necessary :wink:

1 Like

hi @yw4z
I upgraded BTT to 4.396 and this issue has been fixed.

@Andreas_Hegenberg thanks for your help. :+1:

I installed this preset, got some error with it and now I can't launch better touch tool. Using Setapp version. How can I fix this without losing my configurations?

Tried reinstalling
Using this defaults write com.hegenberg.BetterTouchTool BTTSafeModeEnabled YES
And deleting preset folder in ~/Library/Application Support/BetterTouchTool/PresetBundles but it just recreates itself and it's empty anyway

Any ideas?

@asgeirtj
that issue is fixed on latest alpha releases

First try this
• go to ~/Library/Application Support/BetterTouchTool/ folder
• open btt_user_variables.plist
• delete this lines

<key>SWM-FA</key>
	<integer>0</integer>

also you can try btt manually but im not sure SetApp allows this
you can download latest alpha and replace BetterTouchTool.app from
https://folivora.ai/releases/

Updated gumroad page with 1.0.3 version

:hammer_and_wrench: Fixes

  • Right click on minimize button not working on non-active windows
  • Maximize function not uses same method with other resize actions when its triggered with keyboard shortcut
  • BTT starts crashing after SWM install. This one is solved on latest alpha release of BTT and also i wanted to fix on SWM side because some users might use old versions of BTT

I use Setapp which is version:


this seems to be the newest version of better touch tool:

is there some alpha version also? I'm confused

@asgeirtj can you use an older version of BTT on SetApp. i guess that bug appeared in 4.375. wait for an answer from Andreas
@Andreas_Hegenberg can you look at this. im not sure how SetApp works

The SetApp version will be updated soon, alpha releases are not available on SetApp currently