Show / Hide specific app is not working as expected

Back to MacOS, always used this in my workflow to launch terminal. Seems broken now, cannot determine behaviour, sometimes works, sometimes not.

Here's my shortcut:


[
  {
    "BTTLastUpdatedAt" : 1700729092.4545209,
    "BTTTriggerType" : 0,
    "BTTTriggerClass" : "BTTTriggerTypeKeyboardShortcut",
    "BTTPredefinedActionType" : 366,
    "BTTPredefinedActionName" : "Empty Placeholder",
    "BTTAdditionalConfiguration" : "1835049",
    "BTTKeyboardShortcutScope" : 0,
    "BTTKeyboardShortcutKeyboardType" : 2302,
    "BTTUUID" : "EDF66E8D-7804-4232-913A-11FB22B24BB8",
    "BTTTriggerOnDown" : 1,
    "BTTLayoutIndependentChar" : "t",
    "BTTEnabled" : 1,
    "BTTEnabled2" : 1,
    "BTTShortcutKeyCode" : 17,
    "BTTShortcutModifierKeys" : 1835008,
    "BTTOrder" : 4,
    "BTTAutoAdaptToKeyboardLayout" : 0,
    "BTTAdditionalActions" : [
      {
        "BTTLastUpdatedAt" : 1700728525.7761312,
        "BTTTriggerType" : -1,
        "BTTTriggerParentUUID" : "EDF66E8D-7804-4232-913A-11FB22B24BB8",
        "BTTIsPureAction" : true,
        "BTTTriggerClass" : "BTTTriggerTypeKeyboardShortcut",
        "BTTPredefinedActionType" : 177,
        "BTTPredefinedActionName" : "Show \/ Hide Specific Application",
        "BTTGenericActionConfig2" : "{\"BTTShowHideSpecificAppMoveToSpace\":\"BTTShowHideSpecificAppHiddenToCurrentSpace\",\"BTTShowHideSpecificAppOnlyShow\":false,\"BTTShowHideSpecificAppOnlyHide\":false,\"BTTShowHideSpecificAffectedWindow\":\"BTTShowHideSpecificAppAffectLastUsedWindow\",\"BTTShowHideSpecificAppRegex\":\"\",\"BTTShowHideSpecificAppOnlyTreatActiveAsVisible\":true,\"BTTShowHideSpecificAppOnlyIfRunning\":false,\"BTTShowHideSpecificAppCMDN\":false,\"BTTShowHideSpecificAppMoveToCurrentSpace\":false,\"BTTShowHideSpecificAppMoveAllToCurrentSpace\":false}",
        "BTTAppToShowOrHide" : "\/System\/Applications\/Utilities\/Terminal.app",
        "BTTShowHideAppConfig" : "{\"BTTShowHideSpecificAppMoveToSpace\":\"BTTShowHideSpecificAppHiddenToCurrentSpace\",\"BTTShowHideSpecificAppOnlyShow\":false,\"BTTShowHideSpecificAppOnlyHide\":false,\"BTTShowHideSpecificAffectedWindow\":\"BTTShowHideSpecificAppAffectLastUsedWindow\",\"BTTShowHideSpecificAppRegex\":\"\",\"BTTShowHideSpecificAppOnlyTreatActiveAsVisible\":true,\"BTTShowHideSpecificAppOnlyIfRunning\":false,\"BTTShowHideSpecificAppCMDN\":false,\"BTTShowHideSpecificAppMoveToCurrentSpace\":false,\"BTTShowHideSpecificAppMoveAllToCurrentSpace\":false}",
        "BTTKeyboardShortcutKeyboardType" : 0,
        "BTTUUID" : "976E416F-C0D9-4E44-951F-C1A5827E61C6",
        "BTTEnabled" : 1,
        "BTTEnabled2" : 1,
        "BTTShortcutKeyCode" : -1,
        "BTTShortcutModifierKeys" : -1,
        "BTTOrder" : 12,
        "BTTAutoAdaptToKeyboardLayout" : 0
      }
    ]
  }
]

Running on Sonoma 14.1.1
and on BTT 43310 (tried stable, then alpha)
MacBook Pro M1 (on two machines a 14 and 16)

A workaround is to apply it to "All Windows" rather than the "Last Used Window", that seems to work so far.

Your shortcut seems to work fine here.

It could be a permission problem because using the "Last Used Window" option requires permissions to the Accessibility API. Possibly try to delete BetterTouchTool from System Settings => Privacy & Security => Accessibility, then add it back manually. (Quit BTT before doing that)

Tried that just now, quit BTT, removed all the accessbility checks. Added them manually back, started BTT, didn't ask me for more permissions, and I'm seeing the same behaviour. I can live with the show all windows setting for now, but if you want a recording of it, or more info, I can do that as well.

there have been some changes to app activation in macOS Sonoma. I'll check again whether there is anything could influence this!

1 Like

I'm have started getting similar problems. When showing a specific application, the application comes to front, then immediately goes back again. With the "All Windows" setting, it works most of the time, but not always.

With multiple monitors, I also have to make sure the "Don't Change Desktop" setting is active, otherwise the application window might switch displays as well. That's not intended, is it?

Hm. It works again now. I quit BTT, then deactivated the accessibility and restarted BTT. Then reactivated accessibility and upgraded to 4.356. So it's difficult to tell what fixed the issue for me :man_shrugging:

there was a fix for it in 4.356 :wink:

1 Like