Show/Hide doesn't bring to forefront - Monteray 12.0.1 - M1 MB Pro

Use hotkeys (FN+) to Show/Hide applications.

Used to work just fine under Big Sur / M1 Macbook Air but just upgraded to M1 MB Pro running Monteray and pressing FN+ will no longer bring application to forefront if it is visible but not the active window. It now hides the window instead and I have to press the hotkey a second time to get it to the forefront.


Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

M1 MB Pro
Monteray 12.0.1
Version 3.600 (1746)

could you check with the new update I just pushed?

Confirmed that 3.605 (1753) corrects this issue!


1 Like