"Show Custom Context Menu (NEW)" action fails after installation of BTT 4.299-42990

Describe the bug
A problem occurred after installing BetterTouchTool 4.299-42990 over version 4.272-42713. In the earlier version, the "Show Custom Context Menu (NEW)" action was assigned to the gesture "2 Finger Double-Tap." (Apple Magic Trackpad model A1535.) The gesture was assigned for All Apps as well as for Script Debugger, Pages and Numbers. Just to be clear, the same gesture was assigned in those applications with the custom content menu action. The individual Context Menu Items were different between applications.
After installing the newer version, the context menus no longer properly functioned in the individual applications. (The one assigned to All Apps did function.) The gesture did result in the context menu, however selecting any of the individual menu items produced only a beep from the system.
The same gesture and action created from scratch worked. In fact, I discovered that I could copy the "2 Finger Double-Tap" gesture in BTT's Configuration Window's "Groups & Top Level Triggers" and simply paste it back to that same location. Surprisingly, the original gesture now functioned normally. The pasted version did not work normally until BTT was restarted.
The fix for this was relatively easy to implement, but I hope the issue can be resolved so that it is not necessary in the future.

Mac Studio Ultra 2023 (M2 Ultra CPU)
macOS 14.2
Apple Magic Trackpad model A1535

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. crash logs, related issues, etc.):

thanks for reporting! I'm not sure why it worked for you after configuring it again - I think that might have been coincidence. However I think I found the issue that caused this for you initially.
(On Sonoma the context menus behave a bit differently in some situations and I had to make a change to make them work reliably - however there was a little bug in that change).

I hope this is now fixed with 4.301 alpha!

I appreciate such a quick response and fix. I have installed BTT version 4.301 alpha; the contextual menu items work normally.