Shortcuts stop working after using them for a moment

I have defined shortcuts to [open/bring to the front] my most used applications.
I have following config.

image is actually triggered by CAPSLOCK + S, because I remapped capslock to this key.

It is defined in karabiner elements:

And it worked very well for few months and helped me a lot. But now I started to experience problems with this.

I am switching for example from app1 => app2 => app3 => app2 => app1 using shortcuts and after this chain I can't use any other BTT shortcuts.

I can make BTT working again by:

  • restarting BTT or
  • clicking by mouse on any app icon on OSX dock.
  • using alt + tab

Is there any log or another way to debug this?

I tried to reproduce this, but seem to be unable to do so.
Are the non-working shortcuts defined globally or per app?

Which version of BTT are you running?

Thanks for your fast reaction :slight_smile:

globally or per app? Globally
version of BTT: 2.801

Weird, is this always reproducable?

Could you go to the about screen in BTT and click "Export Debug Information"? This will create a folder called BetterTouchToolDebug that you can send to, then I can have a closer look.

Just sent you email with debug information.

is this always reproducable?

It happens all the time.

Ah I think it's related to secure input in iTerm. Could you confirm that disabling secure input fixes it?


I'll check why this is happening and add a workaround.


Yeah, it was it. Thanks a lot for your fast reaction again :slight_smile: