Shortcuts for move to snap area breaks when I switch monitor

I have three shortcuts for moving my windows to left, middle and right snap areas on my external monitor. I'm not using "thirds", so I had to define snap areas instead.

This works great, but when I disconnect the external monitor and the reconnect it, the shortcuts are broken.

My snap areas are still working with manual dragging. When I redefine the shortcuts I notice that the coordinates for the snap area in the shortcut has changed. I think it tried to adapt the coordinates in the shortcut to the smaller monitor.

Is there a setting I have missed or is it a bug?

I have some more insights on this. It turns out that the problem only arise when I switch between my external monitor at home and at work. The two monitors are identical, but I assume that BTT treats them as different monitors via some kind of id.

If my above assumption is correct it would be really great to be able to tell BTT that these two monitors are "the same", and I want the exact same snap area-shortcuts to be applied to both monitors.

Please, could you look into this. I don't know when this happened, but it's probably a regression bug. This short-cut concept has been working great for me before.

In order to have working short-cuts I must now redefine them everytime I switch from home office to real office. I have the exact same monitors, but my snap area short-cuts breaks when I switch monitor.

I do love BTT, but this is to much of a PITA.

Best of all would be for this to be solved in BTT, so I don't have to find another window manager. I'm surprised that no one else seems to have this problem. I thought this issue would rise when people work more and more from home.

To clarify the problem:

  1. You have the exaxt same monitor setup at home and at work.
  2. You use BTT global keyboard shortcuts to move windows to custom snap areas

The custom nap areas seem to be associated with specific resolution and maybe monitor layout for dual monitors. But the keyboard shortcuts are only associated with the snap areas on a specific device.

Hence:

  • The snapareas work fine both at home and at work if I drag windows with the mouse.
  • The keyboard shortcuts only work on one of the setups (i.e. at home)

Is this a problem with a specific brand/model? My setup is:

  • MBP 2020
  • USB-C
  • Dell U3818, 38" super-wide
Imprint | Privacy Policy