Shift down shortcut causing indefinite key press

Describe the bug
I have the UK magic keyboard with numeric keypad. So, I want to change "" key to left shift. When I set up this shortcut and press the "" BTT beings trigger the holding the shift key indefinitely... And while writing this I've just noticed that it's not the "`" key only. Basically shift down doesn't let up, no matter what key it's assigned to.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Mac Mini M1 2020
  • macOS version: 13.0.1 (22A400)
  • BetterTouchTool version: 3.952

Also, just confirmed this happens on my MacBook as well.

So, I tried adding the same shortcut with the "`" key using the "shift up" and set it to trigger on "key up". This solves the problem but only allows only one key to be capitalized when typing.

No idea if this helps, but have you tried the toggle caps lock action instead of shift up/down?

Great idea! I tried it out. It kind of works but not consistently enough.

I appreciate the suggestion!