Send Shortcut to Specific App sometimes stops working - had to reboot Mac

mojave

#1

Describe the bug
It's the second time that all my actions which use "Send Shortcut to Specific App" stopped working. The two times I've tried restarting BTT, but the only thing that had worked is rebooting the machine (didn't tried closing session).
I have some that are triggered through Keyboard shortcuts, and other triggered through Touch Bar : both stopped working. I tried to tick "Bring app to front before sending shortcut", and the app is don't even bring.
Note that I use to use all of these action for months without problems.

Do you have an idea of where it can come from ? It may be related to changes in recent versions (or in new MacOS version), as it's a pretty new issue I encounter.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
At least Keyboard shortcuts & Touch Bar

Device information:

  • Type of Mac: MacBook Pro 2018
  • macOS version: 10.14.3
  • BetterTouchTool version: 2.725

#2

I'm seeing strange behaviour which might be related.

I have 'vim-ish' shortcuts set up for iTerm & Chrome where Hyper+H / Hyper+L cycle backwards and forwards between tabs.

In iTerm they are remapped to keyboard shortcuts, whereas in Chrome they send sent (see below) keyboard shortcuts to Google Chrome.

When I run the shortcuts in iTerm it brings Chrome to the front and executes the shortcut there. When I alt+tab back to iTerm I have to wait / hit Esc a few times before it will behave the expected way again.

In my case I'm mapping Hyper to capslock using Karabiner.

When I disable the Chrome shortcuts, the iTerm shortcuts don't bring Chrome to the foreground, although I'm still getting the delay occasionally.

...and while writing this, I decided to delete the Chrome shortcuts altogether and replace Send to Specific App with the more simple "Trigger Other Keyboard Shortcut" - now it seems to work fine

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Keyboard shortcuts

Device information:

  • Type of Mac: MacBook Pro 15-inch 2018
  • macOS version: 10.14.2
  • BetterTouchTool version: 2.717

#3

I'm having the same sort of issues with Touch Bar tmux and vim shortcuts sent to Terminal. They worked great for a long time but they don't work at all now.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Keyboard shortcuts

Device information:

  • Type of Mac: MacBook Pro 2018
  • macOS version: 10.14.4
  • BetterTouchTool version: 2.725

#4

Uh sorry, somehow I seem to have accidentally added a character to a function name (thereby breaking it) and didn't notice.
Will be fixed with the next alpha (later today or tomorrow)


#5

I was coming here to correct myself, rebooting in fact doesn't solve the issue. :smiley:

Glad to know you found the issue ! :ok_hand: