"Send Shortcut To Specific App" & "Show/Hide Specific Application" TB button actions not working

Describe the bug
My "Send Shortcut To Specific App" and "Show/Hide Specific Application" TB button actions are no longer working.

Is anyone else having issues? I would like to know if this is only affecting my machine.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar

Device information:

  • Type of Mac: MacBook Pro
  • macOS version: 10.14.5
  • BetterTouchTool version: 3.04

Same problem here, but am on v2.9, 2019 MacBook Pro, macOS 10.14.5.

Works fine on my other laptop (MacBook 12", macOS 10.13).

Just updated to BTT 3.04. Issue persists.

Interesting. When did you start having issues with your TB buttons?

This bug is a show stopper for me. My entire workflow depends on these actions working.

Any help would be appreciated.

I didn't notice that you were having issues with the TB. My problem arises with keyboard shortcuts, e.g. using Cmd-Opt-Ctrl Space to toggle Spotify play. I have it set to bring the app to the foreground, but it doesn't work. Works fine on my 12" Macbook (which has no TB, by the way). I guess the bug doesn't manifest in 10.13 and/or MacBook.

Pretty frustrating. I bought BTT mainly for this reason.

I'll look into this soon.
For now you can always downgrade to an older BTT version, probably one before the current release cycle like 2.717b should work: https://bettertouchtool.net/releases

1 Like

Thanks. Tried downgrading, but none of my settings show up. I guess I'll wait until you have a fix.

However, as a test, I defined the Spotify triggering shortcut, and that worked fine. But I have too many shortcuts to redefine them all :slight_smile:

Ah, so it happens only for existing shortcuts, not for new ones? (You can export the current preset in the new version and import it in your old version if you want to)

No, they are all new. I just got the 2019 MacBook Pro, and redefined all my shortcuts manually. None of the "Send Shortcut To Specific App" ones work.

Ah sorry, I misunderstood. You redefined it in the old version - got it.

Should be fixed in the latest alpha version (3.05), which is currently uploading and should be available soon.

1 Like

3.05alpha works for me! Thanks :slight_smile:

Mine is still broken on 3.05. I'm good about updating BTT as soon as I get the prompt, and it only broke today when I got one, so I'm pretty sure that 3.05 introduced the break on my setup. Also, when I pull up the UI to see what's going on, it quickly crashes as I do things like try to set a new keyboard shortcut for my "Show/Hide Specific Application" shortcuts

Seems to work fine here on 3.05. Are there crashlogs in the macOS console.apps under "User Reports" for BetterTouchTool?

I've also been experiencing this issue for about a week now, though it is occurring while using trackpad gestures and presses rather than touchbar inputs. I tried updating to alpha version 3.061 last night to see if that might somehow fix it, and that hasn't affected the issue at all. Curiously, I've noticed that deleting the triggers and actions associated with the show/hide app command and adding them again causes them to work again, though they stop working sometime later. I haven't been able to identify exactly what causes this change. Also when these triggers/actions aren't working, sometimes BTT will randomly just randomly quit while editing them.

Could you copy & paste a non-working one here? (Just select it in BTT, press cmd+c, then come back here and press cmd+v)

"BTTTriggerType" : 165,
"BTTTriggerTypeDescription" : "2 Finger Swipe From Left Edge (start outside of the trackpad on the aluminum)",
"BTTTriggerClass" : "BTTTriggerTypeTouchpadAll",
"BTTPredefinedActionType" : 177,
"BTTPredefinedActionName" : "Show / Hide Specific Application",
"BTTAppToShowOrHide" : "com.tapbots.TweetbotMac",
"BTTEnabled2" : 1,
"BTTAlternateModifierKeys" : 0,
"BTTUUID" : "E11602F1-1C54-4010-8E26-8D0FC6C18F17",
"BTTNotesInsteadOfDescription" : 0,
"BTTEnabled" : 1,
"BTTModifierMode" : 0,
"BTTOrder" : 3,
"BTTDisplayOrder" : 0,
"BTTTriggerConfig" : {
"BTTNoTouchTimeout" : 0,
"BTTTriggerRestrictions" : "0",
"BTTGestureForceFeedbackPattern" : 1

I think it should wok correctly again with the latest alpha!

I have installed the latest version. Touch Bar buttons that had show/hide applications function do not work. If I try to edit / change the function of those buttons BTT suddenly closes and restarts. Previously, adding new show/hide functions was not possible but that is not a problem anymore i.e. I can now add new Show/Hide buttons but cannot use or edit my old ones.

are you on 3.069 alpha? Could you copy & paste one of the non-working ones here?