Screenshot Edit works then crashed BT when using Markup on Ventura Intel iMac


I am running version 2.428 of BT which seems to be the latest. I tried searching for Alpa update but nothing is coming, only asking me to upgrade to the latest version which I don't need if this bug is fixed.

The bug:

I assigned a mouse sketch action to take a screenshot. Once the screen shot is showing, I click the edit button so I can get to Markup. I can start marking up with no problem until I switch to another application, then BT report a crash and asks me to reopen BT.

As long as I am on the markup screen and I don't switch to another window on my Mac, there is no issue, but once I touch another window or switch apps, BT crashed.

This by far is the best feature of BT for me, and it is very disappointing that it crashed as I can send the screen to my iPad within the markup, and start marking using my Apple Pencil. However, it crashes loosing all the markups.

Please advise if this is something will be fixed on this existing version or the new version? or if there is a workaround? the worst thing would be is to pay for another upgrade that also has the same bug.

I am using an intel iMac running Ventura.
Also, is there an email for tech support?

Thank you very much

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

unfortunately 2.428 is a very old version that was still developed by my previous company (sometime in 2017 or 2018). I think all 3.x version contain fixes for the latest macOS versions to prevent this issue.

I’d recommend to create a backup of your configuration (export your preset) and try a current version from https://

Ok, I am ok to purchase the new version, But what if I encounter the same bug? do I get a refund?

Thank you

Is there a free trial for the latest version that I can test before I buy?

Thank you

As far as I know you can test the new version 45 days for free. :slightly_smiling_face:

1 Like

Great, how can I get the 45 days, it is asking me to pay on the website?

Just download the latest version here

Perfect, thank you very much.

welcome. Have seen what you are advised?

I just opened the new version, and it is disabled saying trial expired already. Yes, I did backup my presets. How do I reactivate the trial version?


any idea how to enable the trial back? all what I want is to see if this bug is fixed.


Unfortunately, I do not know. I can only speculate ... maybe if you delete BTT completely ... but rather wait for what the developer tells you.

unfortunately that usually means you have already tried the trial on a 3.x version previously.
There is no official way to fully reset the trial.

You can purchase a new license, if it does not work I’ll refund/deactivate it again.

1 Like